summaryrefslogtreecommitdiff
path: root/dev-python/ipywidgets
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/Manifest2
-rw-r--r--dev-python/ipywidgets/ipywidgets-8.1.1.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
index aa3e3ada98df..69b132aecfd8 100644
--- a/dev-python/ipywidgets/Manifest
+++ b/dev-python/ipywidgets/Manifest
@@ -1,3 +1,5 @@
DIST ipywidgets-8.1.0.tar.gz 116121 BLAKE2B dbe8f137294820c6e2da7aaa2ffa1a3b13da30888d70384a174bbc29f85e0e826968e4ccb719bf8ca5d3abce342b1e594a35e814e8b32ac52229ead36b9a068b SHA512 39e3b20420e24eb119b584a9edc364d62573550edde41d0f881ff20649877b61aea80df31b95102e38953256b612ced28d9b5afb22a17cc04a3f258d79f43058
+DIST ipywidgets-8.1.1.tar.gz 116420 BLAKE2B 9f138178dc213cac8d3c21a366f47c10675d8d74eb3e29f07c12b10c3a99281896f15afc4f609a4f9ad5f0eac5c60507b10cc98a01500d46150dd6ce36b15b3c SHA512 287f4cb56fe08b1ca01c7f226d7c8a1471d33bb1c36053e705326356c82de8686d6d59be0b50c3016c6c168c743f37de366a5fdf5f8a00c9d0678773e8c1618e
EBUILD ipywidgets-8.1.0.ebuild 1055 BLAKE2B e48c3baca72c123f12fee4d1851500b1cfe16d000d816f56f53d396986fbb428288252473da4d5ae921f58bd15ec674f724b4bfa429a6529429c36147f7b8a4c SHA512 2fad0e747fdb2225643adab4e55026dc6bee367a6d77ef01f3be25bd033b7b0f70dc793150bb8cfacfae61bd701d20d127361df45fd691e5370442c3bb67003c
+EBUILD ipywidgets-8.1.1.ebuild 1063 BLAKE2B 342251f3818b7e0b8f8f9cdb98c908eeeec5f9f95aaa5e8da993b7af526736b7eb60b61839623a07cb88a07496ffda06d61280faf023967cb2b1da2ee03d2099 SHA512 9d589e082aaa29d32f8f4a98cf0287bc23e51ca57dff9db90e2b3be0cc323f5c3d69085065c2a88c9778a7686099d6de3c3f50469f4c167d7f26dd197c827d57
MISC metadata.xml 537 BLAKE2B 1f3b91be328b958870a72b5ce438c3e5bf67efd072b59dcb5ae77a9b89334e726af4fe8771221a7b728905cef4175cf7e0a49b11c651a7c0520b5cb032085985 SHA512 cb8092ea7a06e309a26abb78f5ddfd4a91f416e15374d2b59fb5086a64cc13f3dd408e18caa6719d12b1f18f762469a72a1027b2a047db626c51d22a5f304e54
diff --git a/dev-python/ipywidgets/ipywidgets-8.1.1.ebuild b/dev-python/ipywidgets/ipywidgets-8.1.1.ebuild
new file mode 100644
index 000000000000..dfb29d772533
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-8.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="
+ https://ipywidgets.readthedocs.io/
+ https://github.com/jupyter-widgets/ipywidgets/
+ https://pypi.org/project/ipywidgets/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/comm-0.1.3[${PYTHON_USEDEP}]
+ >=dev-python/ipython_genutils-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-4.0.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # upstream hack to autoconfigure ipywidgets in jupyter
+ # we don't have jupyterlab_widgets packaged
+ sed -i -e '/jupyterlab_widgets/d' setup.cfg || die
+ distutils-r1_src_prepare
+}