summaryrefslogtreecommitdiff
path: root/dev-python/ipython
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/Manifest3
-rw-r--r--dev-python/ipython/files/ipython-8.24.0-mpl-3.9.patch72
-rw-r--r--dev-python/ipython/files/ipython-8.24.0-pytest-8.patch125
-rw-r--r--dev-python/ipython/ipython-8.24.0-r1.ebuild182
4 files changed, 382 insertions, 0 deletions
diff --git a/dev-python/ipython/Manifest b/dev-python/ipython/Manifest
index 507a2855befc..6819da0e920d 100644
--- a/dev-python/ipython/Manifest
+++ b/dev-python/ipython/Manifest
@@ -1,4 +1,7 @@
AUX 2.1.0-substitute-files.patch 1017 BLAKE2B 70577eb950a18345804a2a4b750bd233dc6a0b6bbdb524dfc66e0f4a7c69b0eeb2d35efb9d1845d567a11d1afa7881068b4757e42b9baf24dc01ba3026608a38 SHA512 fc4c9e12267ac5f04a2e16ad27334a093638538b8149ff380099fcbeb674a276ab9eb624a508010e37f82c05d5f7ab527a80e386b3e7b61c123ecb8effd9d542
+AUX ipython-8.24.0-mpl-3.9.patch 2792 BLAKE2B 6a06595e59a6f86f9f211a3a37d2d5792d9ce009832fa42455080a88cb9e6d3c18e385dbc5f6bde34c7384d8af06540bd313d26f02834a9edc025c435de7d5af SHA512 f1ca0c37c4335163aeab83174d253a43b80fc323a902f968f27c0d20356e85b2276f14babf02a3fd7184fcdd421fdaf4fded0e03d8f806825a8669336d6ec8c7
+AUX ipython-8.24.0-pytest-8.patch 4709 BLAKE2B 213f1bef47a0be8fd8d98e6eaf61933b19d8eb50a55157461f3b984e884450f4ae0abdd96bf13fd084c93aa70044f6e710af2e833de812474bcd82a130782dd9 SHA512 5231ef70de1edaeb2acb704c1422103fd01f6b41fd27fa5496bc16a382770ea61a0888f246ec1997e4436cdf203648ed0931a222a2d65398585a2981b3354ef8
DIST ipython-8.24.0.tar.gz 5491819 BLAKE2B 49ca26f4ab6ceb7c787038db5b1073790d7a32cb96951bcc2ffa4ac05b3a689507e654344fda196560e2dc4b9e2225335e27bc3fb7472ba487adebb1ebba44e1 SHA512 adf032a93e94e1e8008a1cc106fb348d0bccb914a335e0ad04490531e7a7d16e7a2dc4a345f7faf1b3151d60a649413fa78130688cb59de088e5eb4291689310
+EBUILD ipython-8.24.0-r1.ebuild 5036 BLAKE2B 0f2a421056468ef2327034c28fbad443544a4b20633c2b61bd7c9e8803ea37758055da696353666ec43dc8d8875c31ef8e7cbab62adc8a257067af356fa8fdbc SHA512 544a31ec8c466aa8c1afe3c57f761bc27ca3819838d46626230632fc63a819d62c1d730f832b0b5afec0e201e4fd93d29f7add3e5c4e5175efc38c663b85d4e6
EBUILD ipython-8.24.0.ebuild 4896 BLAKE2B d1bbab9880fe8d356f8d5c753c7f731ecd339272f769d025f7f6f1acc40b9776f612b6586334038ed86334fea8eb8a5f65d9245c9550644a79461f7731a71471 SHA512 aba6aa15e071dbd616f8ada72e0ba68424857b2fe58152e2697d920bfa77036804dda56155cd40bdf11a1aee6ecb29dc05cbc5f22e27d2a4af91a655e3de1e82
MISC metadata.xml 2802 BLAKE2B 2fb6773ad4ef10d531f978e3ed40f6d99cf1586ec6d7cf2bf7e60fd5d640d082a0946651e0a066993320ffeaace3426066ca24c325926b62125ae91816707128 SHA512 965c3e36e05475d9454af8219b84e080d4c83d775f8a7e20a4951a82246d672c46fd3cb1fff5f8664d0ce8e8fcb846de6f15abc4575db3a6b7d87209194bcecc
diff --git a/dev-python/ipython/files/ipython-8.24.0-mpl-3.9.patch b/dev-python/ipython/files/ipython-8.24.0-mpl-3.9.patch
new file mode 100644
index 000000000000..927cc95ccf29
--- /dev/null
+++ b/dev-python/ipython/files/ipython-8.24.0-mpl-3.9.patch
@@ -0,0 +1,72 @@
+diff --git a/IPython/core/pylabtools.py b/IPython/core/pylabtools.py
+index 1f5a11f37e..4287834418 100644
+--- a/IPython/core/pylabtools.py
++++ b/IPython/core/pylabtools.py
+@@ -345,8 +345,10 @@ def find_gui_and_backend(gui=None, gui_select=None):
+ backend = matplotlib.rcParamsOrig["backend"]
+ backend, gui = backend_registry.resolve_backend(backend)
+ else:
++ gui = _convert_gui_to_matplotlib(gui)
+ backend, gui = backend_registry.resolve_gui_or_backend(gui)
+
++ gui = _convert_gui_from_matplotlib(gui)
+ return gui, backend
+
+ # Fallback to previous behaviour (Matplotlib < 3.9)
+@@ -509,10 +511,28 @@ def _list_matplotlib_backends_and_gui_loops() -> list[str]:
+ if _matplotlib_manages_backends():
+ from matplotlib.backends.registry import backend_registry
+
+- ret = backend_registry.list_all() + backend_registry.list_gui_frameworks()
++ ret = backend_registry.list_all() + [
++ _convert_gui_from_matplotlib(gui)
++ for gui in backend_registry.list_gui_frameworks()
++ ]
+ else:
+ from IPython.core import pylabtools
+
+ ret = list(pylabtools.backends.keys())
+
+ return sorted(["auto"] + ret)
++
++
++# Matplotlib and IPython do not always use the same gui framework name.
++# Always use the approprate one of these conversion functions when passing a
++# gui framework name to/from Matplotlib.
++def _convert_gui_to_matplotlib(gui: str | None) -> str | None:
++ if gui and gui.lower() == "osx":
++ return "macosx"
++ return gui
++
++
++def _convert_gui_from_matplotlib(gui: str | None) -> str | None:
++ if gui and gui.lower() == "macosx":
++ return "osx"
++ return gui
+diff --git a/IPython/core/tests/test_pylabtools.py b/IPython/core/tests/test_pylabtools.py
+index 4099f04044..6bddb34807 100644
+--- a/IPython/core/tests/test_pylabtools.py
++++ b/IPython/core/tests/test_pylabtools.py
+@@ -276,11 +276,11 @@ def test_figure_no_canvas():
+ # name is gui
+ ("gtk3", "gtk3", "gtk3agg"),
+ ("gtk4", "gtk4", "gtk4agg"),
+- ("headless", "headless", "agg"),
++ ("headless", None, "agg"),
+ ("osx", "osx", "macosx"),
+ ("qt", "qt", "qtagg"),
+ ("qt5", "qt5", "qt5agg"),
+- ("qt6", "qt6", "qt6agg"),
++ ("qt6", "qt6", "qtagg"),
+ ("tk", "tk", "tkagg"),
+ ("wx", "wx", "wxagg"),
+ # name is backend
+@@ -301,8 +301,6 @@ def test_figure_no_canvas():
+ ("qtcairo", "qt", "qtcairo"),
+ ("qt5agg", "qt5", "qt5agg"),
+ ("qt5cairo", "qt5", "qt5cairo"),
+- ("qt6agg", "qt", "qt6agg"),
+- ("qt6cairo", "qt", "qt6cairo"),
+ ("tkagg", "tk", "tkagg"),
+ ("tkcairo", "tk", "tkcairo"),
+ ("webagg", "webagg", "webagg"),
diff --git a/dev-python/ipython/files/ipython-8.24.0-pytest-8.patch b/dev-python/ipython/files/ipython-8.24.0-pytest-8.patch
new file mode 100644
index 000000000000..04f1a1534ac5
--- /dev/null
+++ b/dev-python/ipython/files/ipython-8.24.0-pytest-8.patch
@@ -0,0 +1,125 @@
+From 7df70a3cd79068be6f98596e427d60a5d0cfe5b3 Mon Sep 17 00:00:00 2001
+From: Steve Kowalik <steven@wedontsleep.org>
+Date: Thu, 23 May 2024 13:00:43 +1000
+Subject: [PATCH] Support pytest 8.1+ changes in pytest plugin
+
+Pytest 8.1 has also changed the plugin API, as well as required new
+keyword arguments. I've shifted the pytest version calculation to the
+module level so we can use it everywhere, and continue supporting all
+versions of pytest that we can.
+
+Fixes #14390
+---
+ IPython/testing/plugin/pytest_ipdoctest.py | 36 ++++++++++++++++------
+ 1 file changed, 26 insertions(+), 10 deletions(-)
+
+diff --git a/IPython/testing/plugin/pytest_ipdoctest.py b/IPython/testing/plugin/pytest_ipdoctest.py
+index fc8af13b579..40a3ae92b40 100644
+--- a/IPython/testing/plugin/pytest_ipdoctest.py
++++ b/IPython/testing/plugin/pytest_ipdoctest.py
+@@ -38,7 +38,11 @@
+ from _pytest.compat import safe_getattr
+ from _pytest.config import Config
+ from _pytest.config.argparsing import Parser
+-from _pytest.fixtures import FixtureRequest
++
++try:
++ from _pytest.fixtures import TopRequest as FixtureRequest
++except ImportError:
++ from _pytest.fixtures import FixtureRequest
+ from _pytest.nodes import Collector
+ from _pytest.outcomes import OutcomeException
+ from _pytest.pathlib import fnmatch_ex, import_path
+@@ -69,6 +73,8 @@
+ # Lazy definition of output checker class
+ CHECKER_CLASS: Optional[Type["IPDoctestOutputChecker"]] = None
+
++pytest_version = tuple([int(part) for part in pytest.__version__.split(".")])
++
+
+ def pytest_addoption(parser: Parser) -> None:
+ parser.addini(
+@@ -143,7 +149,7 @@ def pytest_collect_file(
+ return None
+
+
+-if int(pytest.__version__.split(".")[0]) < 7:
++if pytest_version[0] < 7:
+ _collect_file = pytest_collect_file
+
+ def pytest_collect_file(
+@@ -448,7 +454,7 @@ def reportinfo(self) -> Tuple[Union["os.PathLike[str]", str], Optional[int], str
+ assert self.dtest is not None
+ return self.path, self.dtest.lineno, "[ipdoctest] %s" % self.name
+
+- if int(pytest.__version__.split(".")[0]) < 7:
++ if pytest_version[0] < 7:
+
+ @property
+ def path(self) -> Path:
+@@ -521,7 +527,7 @@ def collect(self) -> Iterable[IPDoctestItem]:
+ self, name=test.name, runner=runner, dtest=test
+ )
+
+- if int(pytest.__version__.split(".")[0]) < 7:
++ if pytest_version[0] < 7:
+
+ @property
+ def path(self) -> Path:
+@@ -636,20 +642,26 @@ def _find(
+ )
+
+ if self.path.name == "conftest.py":
+- if int(pytest.__version__.split(".")[0]) < 7:
++ if pytest_version[0] < 7:
+ module = self.config.pluginmanager._importconftest(
+ self.path,
+ self.config.getoption("importmode"),
+ )
+ else:
++ kwargs = {"rootpath": self.config.rootpath}
++ if pytest_version >= (8, 1):
++ kwargs["consider_namespace_packages"] = False
+ module = self.config.pluginmanager._importconftest(
+ self.path,
+ self.config.getoption("importmode"),
+- rootpath=self.config.rootpath,
++ **kwargs,
+ )
+ else:
+ try:
+- module = import_path(self.path, root=self.config.rootpath)
++ kwargs = {"root": self.config.rootpath}
++ if pytest_version >= (8, 1):
++ kwargs["consider_namespace_packages"] = False
++ module = import_path(self.path, **kwargs)
+ except ImportError:
+ if self.config.getvalue("ipdoctest_ignore_import_errors"):
+ pytest.skip("unable to import module %r" % self.path)
+@@ -671,7 +683,7 @@ def _find(
+ self, name=test.name, runner=runner, dtest=test
+ )
+
+- if int(pytest.__version__.split(".")[0]) < 7:
++ if pytest_version[0] < 7:
+
+ @property
+ def path(self) -> Path:
+@@ -701,11 +713,15 @@ def func() -> None:
+
+ doctest_item.funcargs = {} # type: ignore[attr-defined]
+ fm = doctest_item.session._fixturemanager
++ kwargs = {"node": doctest_item, "func": func, "cls": None}
++ if pytest_version <= (8, 0):
++ kwargs["funcargs"] = False
+ doctest_item._fixtureinfo = fm.getfixtureinfo( # type: ignore[attr-defined]
+- node=doctest_item, func=func, cls=None, funcargs=False
++ **kwargs
+ )
+ fixture_request = FixtureRequest(doctest_item, _ispytest=True)
+- fixture_request._fillfixtures()
++ if pytest_version <= (8, 0):
++ fixture_request._fillfixtures()
+ return fixture_request
+
+
diff --git a/dev-python/ipython/ipython-8.24.0-r1.ebuild b/dev-python/ipython/ipython-8.24.0-r1.ebuild
new file mode 100644
index 000000000000..abefb66944bd
--- /dev/null
+++ b/dev-python/ipython/ipython-8.24.0-r1.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE='readline(+),sqlite,threads(+)'
+
+inherit distutils-r1 optfeature pypi virtualx
+
+DESCRIPTION="Advanced interactive shell for Python"
+HOMEPAGE="
+ https://ipython.org/
+ https://github.com/ipython/ipython/
+ https://pypi.org/project/ipython/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+IUSE="doc examples notebook nbconvert qt5 +smp test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.16[${PYTHON_USEDEP}]
+ dev-python/matplotlib-inline[${PYTHON_USEDEP}]
+ >=dev-python/pexpect-4.3[${PYTHON_USEDEP}]
+ >=dev-python/prompt-toolkit-3.0.41[${PYTHON_USEDEP}]
+ <dev-python/prompt-toolkit-3.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ dev-python/stack-data[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.13.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ ' 3.10)
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10 3.11)
+"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-text/dvipng[truetype]
+ >=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-3.9[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.23[${PYTHON_USEDEP}]
+ dev-python/matplotlib-inline[${PYTHON_USEDEP}]
+ dev-python/pickleshare[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-2[${PYTHON_USEDEP}]
+ dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+RDEPEND+="
+ nbconvert? (
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ $(python_gen_cond_dep '
+ notebook? (
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/widgetsnbextension[${PYTHON_USEDEP}]
+ )
+ qt5? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
+ ' 'python*')
+ smp? (
+ >=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/ipyparallel-6.2.3[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/2.1.0-substitute-files.patch
+ # https://github.com/ipython/ipython/pull/14441
+ "${FILESDIR}/${P}-pytest-8.patch"
+ # https://github.com/ipython/ipython/pull/14420
+ "${FILESDIR}/${P}-mpl-3.9.patch"
+)
+
+python_prepare_all() {
+ # Remove out of date insource files
+ #rm IPython/extensions/cythonmagic.py || die
+ #rm IPython/extensions/rmagic.py || die
+
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ # Rename the test directory to reduce sys.path pollution
+ # https://github.com/ipython/ipython/issues/12892
+ mv IPython/extensions/{,ipython_}tests || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html_noapi
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local -x IPYTHON_TESTING_TIMEOUT_SCALE=20
+ local EPYTEST_DESELECT=(
+ # TODO: looks to be a regression due to a newer dep
+ IPython/core/tests/test_oinspect.py::test_class_signature
+ IPython/core/tests/test_oinspect.py::test_render_signature_long
+ IPython/terminal/tests/test_shortcuts.py::test_modify_shortcut_with_filters
+ )
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # https://github.com/numpy/numpy/issues/25164
+ IPython/lib/tests/test_display.py::TestAudioDataWithoutNumpy
+ )
+ ;;
+ esac
+
+ # nonfatal implied by virtx
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest -p asyncio --asyncio-mode=auto ||
+ die "Tests failed on ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # Create ipythonX.Y symlinks.
+ # TODO:
+ # 1. do we want them for pypy? No. pypy has no numpy
+ # 2. handle it in the eclass instead (use _python_ln_rel).
+ # With pypy not an option the dosym becomes unconditional
+ dosym ../lib/python-exec/${EPYTHON}/ipython \
+ /usr/bin/ipython${EPYTHON#python}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+pkg_postinst() {
+ optfeature "code formatting" dev-python/black
+ optfeature "sympyprinting" dev-python/sympy
+ optfeature "cythonmagic" dev-python/cython
+ optfeature "%lprun magic command" dev-python/line-profiler
+ optfeature "%matplotlib magic command" dev-python/matplotlib-inline
+
+ if use nbconvert; then
+ if ! has_version virtual/pandoc ; then
+ einfo "Node.js will be used to convert notebooks to other formats"
+ einfo "like HTML. Support for that is still experimental. If you"
+ einfo "encounter any problems, please use app-text/pandoc instead."
+ fi
+ fi
+}