summaryrefslogtreecommitdiff
path: root/dev-python/ipykernel
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ipykernel')
-rw-r--r--dev-python/ipykernel/Manifest4
-rw-r--r--dev-python/ipykernel/ipykernel-6.29.4.ebuild80
-rw-r--r--dev-python/ipykernel/ipykernel-6.29.5.ebuild2
3 files changed, 2 insertions, 84 deletions
diff --git a/dev-python/ipykernel/Manifest b/dev-python/ipykernel/Manifest
index ea28e8796044..06e78c00b65e 100644
--- a/dev-python/ipykernel/Manifest
+++ b/dev-python/ipykernel/Manifest
@@ -1,5 +1,3 @@
-DIST ipykernel-6.29.4.tar.gz 162958 BLAKE2B 887d33b433f5fba70273e4020a79bb511bd076fe536c04ebc5f7e838637ff120889789783f9a3a41b4669b0b51d44401215ed3feac413382b953edf9d1b6cb48 SHA512 488d43c1c9f416281b23ba0f31311c7327ef97034d6cf1776392c0f7b193f52f1434e81ae0c45759a0b15354ef9d178c3fc835c6be4408880209e41b91e5602b
DIST ipykernel-6.29.5.tar.gz 163367 BLAKE2B ac1a48093b68a79c9b656cc3960f35ae2e28ac110b4a560b7434b853e37e505034d7822fc2d6557f03e1f82a260abba53cf53ba9dde4fc6fc468fd65fb46875a SHA512 271232ad6168ff00d6eb729bb38804f6a030b85be9bd75341b4af8ca1feb9f3c6b088eff77f4efcc503512559c93f1d78c13904089b7acb5205c4039daf0cea0
-EBUILD ipykernel-6.29.4.ebuild 2343 BLAKE2B 3ec06294d5af46f6752f5ee695e389ea19c2d595cfbf360a16bfd38e133412de1bb64cd9f5537f32e460a7d11b9d4cd1bc85d743efb2c1d13736d6e26dcdd8c5 SHA512 3f135feed7c0c520411ac6588ef410b477adb4125d00e0cf3c15b91e3ae3cbbae287adde418269e1d9747aa1f28addec0463d27e378e39d2aa10a73889e6ea58
-EBUILD ipykernel-6.29.5.ebuild 2513 BLAKE2B ca98fc4e0c7169951ceab23922bfdae6c1e1fa9496f1a2203263e6d1dab7219236f18b7093d420ce1efd2fd794ec9c136d6d4129b901107d2cdf075b63381be6 SHA512 2451d227d94dbf1b0307914a4f76f6047dd8321e362965456d1d99d5648d100eb69600550c019fe494a61467e897828d46b53b072f196ce1c19d4ee51b4ed588
+EBUILD ipykernel-6.29.5.ebuild 2505 BLAKE2B ed9f92b8a19f4d87dc2cbd6c8abb2a69df964c291242b3cc0746d78a408fa0293d617a721467ab418423515f1e323cce61fd82f048e172ca4efaababa521e451 SHA512 38df3ec2496012b01f0fc6560fd5d949551c89539383bef5a59ca5374ad60d0daa325bcec5e50063079ddd6280d0445f09bbcbad05d5b5a4257b8100296ff946
MISC metadata.xml 527 BLAKE2B 4a24cb9d5b801bf94c71c47d0c90b04bc249fb41a794c7b688a5762f08545d1fcfe9e4976aa4f583ecb456458b5f6dfc394349633959444584c0abad0da4be42 SHA512 ed9f0ef12ec5de67a646783243555f1737604a84c78c57b9f7c65137cec8cbc396991411501927f92bd393daad2238c27363ecc9c115031450231c2a4fb2cbb9
diff --git a/dev-python/ipykernel/ipykernel-6.29.4.ebuild b/dev-python/ipykernel/ipykernel-6.29.4.ebuild
deleted file mode 100644
index b780d9ae2f01..000000000000
--- a/dev-python/ipykernel/ipykernel-6.29.4.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 pypi virtualx
-
-DESCRIPTION="IPython Kernel for Jupyter"
-HOMEPAGE="
- https://github.com/ipython/ipykernel/
- https://pypi.org/project/ipykernel/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-
-RDEPEND="
- >=dev-python/comm-0.1.1[${PYTHON_USEDEP}]
- >=dev-python/ipython-7.23.1[${PYTHON_USEDEP}]
- >=dev-python/jupyter-client-8[${PYTHON_USEDEP}]
- >=dev-python/jupyter-core-4.12[${PYTHON_USEDEP}]
- >=dev-python/matplotlib-inline-0.1[${PYTHON_USEDEP}]
- dev-python/nest-asyncio[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-24[${PYTHON_USEDEP}]
- >=dev-python/tornado-6.1[${PYTHON_USEDEP}]
- >=dev-python/traitlets-5.4.0[${PYTHON_USEDEP}]
-"
-# RDEPEND seems specifically needed in BDEPEND, at least jupyter
-# bug #816486
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- <dev-python/pytest-8[${PYTHON_USEDEP}]
- >=dev-python/pytest-asyncio-0.23.5[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/ipyparallel[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # debugpy is actually optional
- sed -i -e '/debugpy/d' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- distutils-r1_python_compile
- # Use python3 in kernel.json configuration, bug #784764
- sed -i -e '/python3.[0-9]\+/s//python3/' \
- "${BUILD_DIR}/install${EPREFIX}/usr/share/jupyter/kernels/python3/kernel.json" || die
-}
-
-src_test() {
- local EPYTEST_DESELECT=(
- # TODO
- tests/test_debugger.py::test_attach_debug
- tests/test_debugger.py::test_breakpoint_in_cell_with_leading_empty_lines
- tests/test_debugger.py::test_rich_inspect_at_breakpoint
- tests/test_debugger.py::test_rich_inspect_not_at_breakpoint
- tests/test_debugger.py::test_set_breakpoints
- tests/test_debugger.py::test_stop_on_breakpoint
- tests/test_debugger.py::test_copy_to_globals
- # hangs?
- tests/test_eventloop.py::test_tk_loop
- # doesn't like pyside2?
- tests/test_eventloop.py::test_qt_enable_gui
- )
-
- virtx distutils-r1_src_test
-}
diff --git a/dev-python/ipykernel/ipykernel-6.29.5.ebuild b/dev-python/ipykernel/ipykernel-6.29.5.ebuild
index 383567063ae2..f5ef2e0c34bf 100644
--- a/dev-python/ipykernel/ipykernel-6.29.5.ebuild
+++ b/dev-python/ipykernel/ipykernel-6.29.5.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
RDEPEND="
>=dev-python/comm-0.1.1[${PYTHON_USEDEP}]