summaryrefslogtreecommitdiff
path: root/dev-python/ip-associations-python-novaclient-ext/ip-associations-python-novaclient-ext-0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ip-associations-python-novaclient-ext/ip-associations-python-novaclient-ext-0.2.ebuild')
-rw-r--r--dev-python/ip-associations-python-novaclient-ext/ip-associations-python-novaclient-ext-0.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/ip-associations-python-novaclient-ext/ip-associations-python-novaclient-ext-0.2.ebuild b/dev-python/ip-associations-python-novaclient-ext/ip-associations-python-novaclient-ext-0.2.ebuild
new file mode 100644
index 000000000000..8d478cad43c7
--- /dev/null
+++ b/dev-python/ip-associations-python-novaclient-ext/ip-associations-python-novaclient-ext-0.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Disk Config extension for python-novaclient"
+HOMEPAGE="https://github.com/rackspace/ip_associations_python_novaclient_ext"
+SRC_URI="mirror://pypi/${PN:0:1}/ip_associations_python_novaclient_ext/ip_associations_python_novaclient_ext-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/ip_associations_python_novaclient_ext-${PV}"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/python-novaclient-2.20.0[${PYTHON_USEDEP}]"