summaryrefslogtreecommitdiff
path: root/dev-python/inline-snapshot
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/inline-snapshot')
-rw-r--r--dev-python/inline-snapshot/Manifest2
-rw-r--r--dev-python/inline-snapshot/inline-snapshot-0.16.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/inline-snapshot/Manifest b/dev-python/inline-snapshot/Manifest
index d6445b37a914..ac1018be3fa3 100644
--- a/dev-python/inline-snapshot/Manifest
+++ b/dev-python/inline-snapshot/Manifest
@@ -1,5 +1,7 @@
DIST inline_snapshot-0.14.2.tar.gz 221204 BLAKE2B b6ead7cafac4c83e4913fc24407f5de86a6ba5f965a67494e5463a3c784b560e063897eb6c351debb33a23a3127efbf51b928173b23641ae0b46f2e627e59b4e SHA512 fd50e80e344e58f92c9de7817515c240921b67c1035cd8b392a4a2e6133a22b22f3f88fac9b75116b4211068933e022683e719dde56d54dd1c55e8dfa7a7caf8
DIST inline_snapshot-0.15.1.tar.gz 232022 BLAKE2B b41494a59269d11b748c07d01091cb6342fd558352c00ae730a38b154d99694b12c993aa6ad339a47f97e2c85680c74db58235676deed4fa135d8b6180d37cd3 SHA512 e505b3e79a6890c1a257241b27ed97ceaa4b82a91f9d9d92f9ceb37e3581be1fe23369d739d5d8d97042cc6936923d526a6b142d678d253f5a29cbb884d16c55
+DIST inline_snapshot-0.16.0.tar.gz 221918 BLAKE2B f6747a806456ff1850427a82e3330917ddad3cc7470417ffd8aa95914fecc0e4d9cb931292b2fda10398156b1c903be43bca2829cccbbc86a8808b1ee0ec4701 SHA512 41820963a475b1940dabb720c38c99b673ce4ca06d99b951eae0f0c3a6517099eca841c0f5baf1ca7f865a35d10f5f7b64196c2712ca8f7db8a858e6160702ce
EBUILD inline-snapshot-0.14.2.ebuild 1678 BLAKE2B cde8554bd5fead7747893e77e1ee38a3d956c1819e3e92fd900d2adac795afae15e2c4a8ad30845524decc71c6b7e25887bb256524287d06c6a68fab9dab5524 SHA512 e59d6915947e53d3842790b091d9b23ba45e87be1e184369d50ccb68dcb104fd7141526cb59e6c23df52bc90b251c6b6bbe644f3de903cfd5c3b163eafa8fa62
EBUILD inline-snapshot-0.15.1.ebuild 1678 BLAKE2B cde8554bd5fead7747893e77e1ee38a3d956c1819e3e92fd900d2adac795afae15e2c4a8ad30845524decc71c6b7e25887bb256524287d06c6a68fab9dab5524 SHA512 e59d6915947e53d3842790b091d9b23ba45e87be1e184369d50ccb68dcb104fd7141526cb59e6c23df52bc90b251c6b6bbe644f3de903cfd5c3b163eafa8fa62
+EBUILD inline-snapshot-0.16.0.ebuild 1678 BLAKE2B cde8554bd5fead7747893e77e1ee38a3d956c1819e3e92fd900d2adac795afae15e2c4a8ad30845524decc71c6b7e25887bb256524287d06c6a68fab9dab5524 SHA512 e59d6915947e53d3842790b091d9b23ba45e87be1e184369d50ccb68dcb104fd7141526cb59e6c23df52bc90b251c6b6bbe644f3de903cfd5c3b163eafa8fa62
MISC metadata.xml 384 BLAKE2B 37af14f95875416431210b572e9c5e96437d773cf53174dec247a9006ad24940f17ae9803a750dd2e1e73f63675f594b326f880bf7d5cb29ff09a8aae4959e60 SHA512 173bd013e023443c9dac349fab3deea6b5e9c2f054052d3362757cc0c46dd89309c509eb6a0f5a5774a7d8acbc55578b629039615a0cb31d74001a8d0db8b680
diff --git a/dev-python/inline-snapshot/inline-snapshot-0.16.0.ebuild b/dev-python/inline-snapshot/inline-snapshot-0.16.0.ebuild
new file mode 100644
index 000000000000..8a7db5cbef33
--- /dev/null
+++ b/dev-python/inline-snapshot/inline-snapshot-0.16.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Create and update inline snapshots in your Python tests"
+HOMEPAGE="
+ https://15r10nk.github.io/inline-snapshot/
+ https://github.com/15r10nk/inline-snapshot/
+ https://pypi.org/project/inline-snapshot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/asttokens-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/black-23.3.0[${PYTHON_USEDEP}]
+ >=dev-python/click-8.1.4[${PYTHON_USEDEP}]
+ >=dev-python/executing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.7.1[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/dirty-equals-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-6.75.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/mypy[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ >=dev-python/pytest-freezer-0.4.8[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.14.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subtests-0.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires pyright
+ 'tests/test_typing.py::test_typing[pyright]'
+ )
+
+ local -x COLUMNS=80
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=inline_snapshot.pytest_plugin,pytest_freezer,pytest_subtests.plugin,xdist.plugin
+ local -x PYTHONPATH=${S}/src
+ epytest -p pytest_mock
+}