summaryrefslogtreecommitdiff
path: root/dev-python/inline-snapshot
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/inline-snapshot')
-rw-r--r--dev-python/inline-snapshot/Manifest3
-rw-r--r--dev-python/inline-snapshot/inline-snapshot-0.13.4.ebuild56
-rw-r--r--dev-python/inline-snapshot/metadata.xml12
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/inline-snapshot/Manifest b/dev-python/inline-snapshot/Manifest
new file mode 100644
index 000000000000..b6423f89976f
--- /dev/null
+++ b/dev-python/inline-snapshot/Manifest
@@ -0,0 +1,3 @@
+DIST inline_snapshot-0.13.4.tar.gz 215264 BLAKE2B 911bb7007fd35c68e0e42fb915e284394e45b7b510de875827282fc6dadf7f467a6da1efa626e9b2c348750709aea0399bcd7869dc181ab7a2121f76206404a8 SHA512 724d72984399712611c0eea5129b86b6650bdce1a4331255cf30b806ae6f03a33aa51de9f6353e84ae09ec8f6738372964f380a622481b5bf1db1e9baaa5bf00
+EBUILD inline-snapshot-0.13.4.ebuild 1454 BLAKE2B fe9a82b2567703812eed241911c926d129bb41cfbb8e8361638700090986a761b2445749653a346fcb6c19b2694b44cb7157c1a43136501bc2887aead2d3d33e SHA512 90fd2383b9b15dae2c4a87449a350ba09e6296f49d4f1ee40e586bf57a2863d9c1ee830d4945aa72b6b617d9768baa58602e43908342db2c8b59f5cfa6191ca0
+MISC metadata.xml 384 BLAKE2B 37af14f95875416431210b572e9c5e96437d773cf53174dec247a9006ad24940f17ae9803a750dd2e1e73f63675f594b326f880bf7d5cb29ff09a8aae4959e60 SHA512 173bd013e023443c9dac349fab3deea6b5e9c2f054052d3362757cc0c46dd89309c509eb6a0f5a5774a7d8acbc55578b629039615a0cb31d74001a8d0db8b680
diff --git a/dev-python/inline-snapshot/inline-snapshot-0.13.4.ebuild b/dev-python/inline-snapshot/inline-snapshot-0.13.4.ebuild
new file mode 100644
index 000000000000..1de2d341db5f
--- /dev/null
+++ b/dev-python/inline-snapshot/inline-snapshot-0.13.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Create and update inline snapshots in your Python tests"
+HOMEPAGE="
+ https://15r10nk.github.io/inline-snapshot/
+ https://github.com/15r10nk/inline-snapshot/
+ https://pypi.org/project/inline-snapshot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/asttokens-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/black-23.3.0[${PYTHON_USEDEP}]
+ >=dev-python/click-8.1.4[${PYTHON_USEDEP}]
+ >=dev-python/executing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.7.1[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/dirty-equals-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-6.75.5[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subtests-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/time-machine-2.10.0[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires pyright
+ 'tests/test_typing.py::test_typing[pyright]'
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=inline_snapshot.pytest_plugin,time_machine,pytest_subtests.plugin,xdist.plugin
+ local -x PYTHONPATH=${S}/src
+ epytest
+}
diff --git a/dev-python/inline-snapshot/metadata.xml b/dev-python/inline-snapshot/metadata.xml
new file mode 100644
index 000000000000..0a05fdcc6e4f
--- /dev/null
+++ b/dev-python/inline-snapshot/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">15r10nk/inline-snapshot</remote-id>
+ <remote-id type="pypi">inline-snapshot</remote-id>
+ </upstream>
+</pkgmetadata>