summaryrefslogtreecommitdiff
path: root/dev-python/inflect
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/inflect')
-rw-r--r--dev-python/inflect/Manifest2
-rw-r--r--dev-python/inflect/inflect-7.5.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/inflect/Manifest b/dev-python/inflect/Manifest
index b493b9c215d0..885a80a7f4c5 100644
--- a/dev-python/inflect/Manifest
+++ b/dev-python/inflect/Manifest
@@ -1,3 +1,5 @@
DIST inflect-7.4.0.tar.gz 72730 BLAKE2B eaaaa46a1f710f5b05165f3f894eb5a2437908299146369a2537a675a1d50facba56c7a9efa2e459b7cfb95a4f2c5f615d64948fb278a4a990423b40414f701a SHA512 fe3658a2f4c9303db90604268a525112c6a67f66ed37f6fbe76cd04a008658362e682413297dc1fcae6e6a0415098f3adaf0f205b781e1e24a050f59c9dc9021
+DIST inflect-7.5.0.tar.gz 73751 BLAKE2B a17c5cb5bfcd10530f29537335ffd1b4725fb1f53e78ef7ce1f40a3031fa486baae3400878e575c8ce6a77b4953332f051ec65dcba024a14c527301e51079edb SHA512 ee9f69dff451017a2aad2226d8c6ae02b4b7b4bc4d4c49f3efee50d85eeef43c49c6c6ef3e7f30fa2c5ef21e065ff5242140d5a98bc71af17c7e70d9e75e54c1
EBUILD inflect-7.4.0.ebuild 727 BLAKE2B d12346b3c9b5a89f075a897b91f88b2771a3e9ecb6f8c4816164ce0f2381590e3c0cabc9abf73e6154323f1ee35ed1466a10201d8a2afa9fd1bc7e3a1f3a8015 SHA512 826e2341b407c89ead864180e10a0b4e63226ed4bdf34939c19c91e6cee8765962a7043d021ad074c156292506e9ee8857f756254947adba483ea5ed189d42a1
+EBUILD inflect-7.5.0.ebuild 734 BLAKE2B 5049574dba0144b16373a75a90dac41dc33915c3cc9a76a72f4b011865426399671c498048ca543ccba848c406dd5bbc44d972700e3615a6a4621f19cfc29b6d SHA512 5e80dd2ba891d18033776ca3c4c6216463f75118a0036fb9581b56ed7614c247940e6da1833ab645c485dba78826cdd488a0674cde0e22b84ba381ef5b0f56f6
MISC metadata.xml 557 BLAKE2B 1a327bb3ea2f7ecb0b3100d9f443c9c0c20a89f1e560eac79cef20a6f12855355dab9c71bab94881774e2be6fc2b4bd9530e1155caecdf687228db259ed34bba SHA512 d719ba7da2f6544cada37998dbc6b104cebb6419ab65bd164411928953c5898da2f5f2f789b72d41f7b46ee7a5570fc6646d331e0df39b34c1fa0685fb9165ab
diff --git a/dev-python/inflect/inflect-7.5.0.ebuild b/dev-python/inflect/inflect-7.5.0.ebuild
new file mode 100644
index 000000000000..d1cdcca00005
--- /dev/null
+++ b/dev-python/inflect/inflect-7.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Correctly inflect words and numbers"
+HOMEPAGE="
+ https://pypi.org/project/inflect/
+ https://github.com/jaraco/inflect/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/typeguard-4.0.1[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest