summaryrefslogtreecommitdiff
path: root/dev-python/imagesize/imagesize-1.3.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/imagesize/imagesize-1.3.0-r1.ebuild')
-rw-r--r--dev-python/imagesize/imagesize-1.3.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/imagesize/imagesize-1.3.0-r1.ebuild b/dev-python/imagesize/imagesize-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..62cddd30227a
--- /dev/null
+++ b/dev-python/imagesize/imagesize-1.3.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pure Python module for getting image size from png/jpeg/jpeg2000/gif files"
+HOMEPAGE="https://github.com/shibukawa/imagesize_py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-solaris"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires Internet
+ test/test_get_filelike.py::test_get_filelike
+)