summaryrefslogtreecommitdiff
path: root/dev-python/identify/identify-2.2.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/identify/identify-2.2.12.ebuild')
-rw-r--r--dev-python/identify/identify-2.2.12.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/identify/identify-2.2.12.ebuild b/dev-python/identify/identify-2.2.12.ebuild
new file mode 100644
index 000000000000..c3b147be85a7
--- /dev/null
+++ b/dev-python/identify/identify-2.2.12.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="https://github.com/pre-commit/identify"
+SRC_URI="https://github.com/pre-commit/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="dev-python/editdistance-s[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest