summaryrefslogtreecommitdiff
path: root/dev-python/hypothesis
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest2
-rw-r--r--dev-python/hypothesis/hypothesis-6.14.5.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index ea549f4c4e3a..aa00d8275b19 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,7 +1,9 @@
DIST hypothesis-python-6.14.0.tar.gz 9135056 BLAKE2B 47d1efcee5e1c4037f1a20f08e3bc873fc143a2182bbde07e897812622c4d68923f78ac356bd97ef541566a27a874705eb2438747daaebe84f95fc2a2262bac1 SHA512 f7821449d3bf7f3656b52dad09027e40ea4af1779fcc7c0b995dac55843953fdab3f2ba69eb1b8de8258616f49cf8e5098c6a222d01071916c6f0c9fe184c80b
DIST hypothesis-python-6.14.2.tar.gz 9135496 BLAKE2B f77f0668c4d0c2f5a952e06a40ae7898631804d3406c9711eb30a4e5a11e73ba2772be3cb437aacea2a75cd65f688a2485b98885c19cf743020900b0cf70f08c SHA512 e495e1c471fd4b185e23326700e85bf90635fcc8bf316c758c3285803ff0f7ad0269351b3a7631033495bb6498a8f19cb8661c55248ec5e14ff2a09e0c3af3c1
DIST hypothesis-python-6.14.3.tar.gz 9135537 BLAKE2B 2effb0c68cf3a7a2f7d56c0c46c2ba36cbed4fed35b8a617ec68a721990247370772b986f0492aab112f7420c07409f8d738485ca28f42e7aea919af52611b10 SHA512 1722c5dcf1eb7375fd09d4208851826582808449fcaaa0345f1461d9a531961500a9c888bec5a457efbbb34f8178464b3358a3187b94bb5c783af42b4e7287ce
+DIST hypothesis-python-6.14.5.tar.gz 9135819 BLAKE2B 2e42949f81024038b901231a8446203388c8052ebaacf4a87d21356265fd1c09c9aa8b191dcd65780d45cc52ed9d48bb16440fc553addb4671e0ad901213ef64 SHA512 d047eea19129d5855bee5f012f5c91fe1f0de40228600fadad9c76709f951c003450f613f59848064b58f9d0e559b54b44744ae0aae689687488b6506cc8fe1a
EBUILD hypothesis-6.14.0-r1.ebuild 1753 BLAKE2B 91d322af6a74614d3675c680d21ec4c89297f2717c016f32d4fb5d98243bd4786de42639bae152fb14a8502cbfaac41134e4d4010639b7152559e32157e92b4e SHA512 a864d799d54784324267fbe6c7006288b227f7c8de1162b3d2b5a5cc37ae0e745b4a8f67efc6dae43b56f9755dca232afcf355829fe7f1c7ff5de9176f43fe46
EBUILD hypothesis-6.14.2.ebuild 1761 BLAKE2B 177223cf49ceef902b9ac33296a2d2ecc0228f457f91f686010da2cf11c38b3bda34bcc83d83031b4c49b9241cfe147177ece32fd94dce9af528f4d73b11322a SHA512 24554123c1cee2225cb033bd8a02be43736f58ff67ffce3835a2955e01fb3085c68ebf1d04f1a405e502de33c4a0d91dd9b664d91386343d29ed704d7e7e1034
EBUILD hypothesis-6.14.3.ebuild 1761 BLAKE2B 177223cf49ceef902b9ac33296a2d2ecc0228f457f91f686010da2cf11c38b3bda34bcc83d83031b4c49b9241cfe147177ece32fd94dce9af528f4d73b11322a SHA512 24554123c1cee2225cb033bd8a02be43736f58ff67ffce3835a2955e01fb3085c68ebf1d04f1a405e502de33c4a0d91dd9b664d91386343d29ed704d7e7e1034
+EBUILD hypothesis-6.14.5.ebuild 1761 BLAKE2B 177223cf49ceef902b9ac33296a2d2ecc0228f457f91f686010da2cf11c38b3bda34bcc83d83031b4c49b9241cfe147177ece32fd94dce9af528f4d73b11322a SHA512 24554123c1cee2225cb033bd8a02be43736f58ff67ffce3835a2955e01fb3085c68ebf1d04f1a405e502de33c4a0d91dd9b664d91386343d29ed704d7e7e1034
MISC metadata.xml 755 BLAKE2B da1fcfe4509905d2058d448b0178dacbb87026a3542368d8aa3ffca38edf1cd3d76d9542f8badc0220f5b5c916fdbb054f65b054a361977e0258e475768e3cf3 SHA512 3f046788581ef05937ec8376538cc60628f9d8e25486fc6e4421dd8461a9a085f51540e1d5203ccf85007adf1a978a23da9ac39cc486d698967412eeb3f2a793
diff --git a/dev-python/hypothesis/hypothesis-6.14.5.ebuild b/dev-python/hypothesis/hypothesis-6.14.5.ebuild
new file mode 100644
index 000000000000..536affb7ae13
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.14.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!dev-python/pytest-describe
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}