summaryrefslogtreecommitdiff
path: root/dev-python/hypothesis
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest2
-rw-r--r--dev-python/hypothesis/hypothesis-6.112.0.ebuild103
2 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 71c6e3eee78c..f691d8f7cdf4 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,7 +1,9 @@
DIST hypothesis-6.110.2.gh.tar.gz 9476926 BLAKE2B 8fb0b250e9c49f56d9b0d077db6305ab86c21eed4739605d3a45423cc0d5695be0e27cab351263f7c3526b26453aee38d6b794464052be6154b4158a776cc873 SHA512 2386f75b91e42e20babf5fc78fcc1ed22391bfa144f318074b0efdb4a1575a6db597aa3c00e756ddea24b792f49d9d6269b6aebb8f8aa8c497e98d3bf2771749
DIST hypothesis-6.111.1.gh.tar.gz 9475914 BLAKE2B 90604318db1a47db4eea8376c943c077058f3158c6c5220aa5f60575cc85c8cf97ed2ad435c7351141939e5b6773d013cf27e4ef9ee64bea2705596b3e4fecc7 SHA512 40e73843ba4477a9bd75087b42f92b6e483beac72dc8684a3d20e90b764f2c0773479a44b6107b237bcf17d347aad45a0ecb23ec54e19da08860e1fa86e5e772
DIST hypothesis-6.111.2.gh.tar.gz 9475843 BLAKE2B 69a436586184a205fcb6b4c053e3c5f53a0c19344b2ffbe697d1cc8bcec62815e680783287f857cc64b9e9b66415670185b38405601a09f93e4c325561e567f2 SHA512 405d0a7545d216082f5b75d8b90bf53169481a96a23f8a40685165610dffe2fa2d47397abda98a90db4d281d274a35a201fbbae191fe264cba6be5deb0709042
+DIST hypothesis-6.112.0.gh.tar.gz 9476351 BLAKE2B 1886389d51f09af3127fbeb81ff62618d67203f9ced47507a1c8fdcc90ea1331d37f6937f62f255b47b339c81f686eb1e3e4d9fd496c14565e692fec73b850bd SHA512 9210a611bb5bd02b855057d72565fca1aae72807788433a03ebdddfbe9d44fc454ecd57ebeeb2a9f2d201580929aa44d585615465bde770ccb95aaf1ca1a4239
EBUILD hypothesis-6.110.2.ebuild 2585 BLAKE2B 1687b228255becec81edcbb2c7279a6a33ec75e18ac25e60e35a2aeed0ffccb3263da6de1b1a9950734d8f187df2d6892cfa33abe6dc4986936bfaf6feac80cf SHA512 69c9552dae1cc44bef13a844de12ce9e3e916fbab66610f2755d22ef7513b0d0ee50f5cbe22669a33528bd63acdd96fe52357a58c328921355ff5e3b79397b99
EBUILD hypothesis-6.111.1.ebuild 2593 BLAKE2B 434f71f7fad97f9e06d3e0a459d8d724c7000ea5ee8712f382c9c8f3746550159b272d208d926d389d87c8198452c410197e55a5e8cb5fec33c8a38719d6bf6f SHA512 5447fcdfaaaa7f15efa13eabee95232a4ac40c248ad5a3c9c7c26846e1868ac1ddd62bd3c6cd8375f7a5cb3ad322ee9dbd737699069ee7f1df2bcfcfcde84aa1
EBUILD hypothesis-6.111.2.ebuild 2593 BLAKE2B 434f71f7fad97f9e06d3e0a459d8d724c7000ea5ee8712f382c9c8f3746550159b272d208d926d389d87c8198452c410197e55a5e8cb5fec33c8a38719d6bf6f SHA512 5447fcdfaaaa7f15efa13eabee95232a4ac40c248ad5a3c9c7c26846e1868ac1ddd62bd3c6cd8375f7a5cb3ad322ee9dbd737699069ee7f1df2bcfcfcde84aa1
+EBUILD hypothesis-6.112.0.ebuild 2593 BLAKE2B 434f71f7fad97f9e06d3e0a459d8d724c7000ea5ee8712f382c9c8f3746550159b272d208d926d389d87c8198452c410197e55a5e8cb5fec33c8a38719d6bf6f SHA512 5447fcdfaaaa7f15efa13eabee95232a4ac40c248ad5a3c9c7c26846e1868ac1ddd62bd3c6cd8375f7a5cb3ad322ee9dbd737699069ee7f1df2bcfcfcde84aa1
MISC metadata.xml 492 BLAKE2B c9e9bbd59af55d1f47e5b7a86933c02b47f832122d03eaca56bd3ec9476cf260d91d4fd2da5068845d4525b7cc9f702b515e8d6a0dffa7923f5898cfd44e12a1 SHA512 166b33d6ac887f52d54fb9d556102038c00650a597d2de1c3aad3f8b5e136e9b6b7db31f05f3379435e4c5f943156d5839d78fc95461af411037a3162ea6705e
diff --git a/dev-python/hypothesis/hypothesis-6.112.0.ebuild b/dev-python/hypothesis/hypothesis-6.112.0.ebuild
new file mode 100644
index 000000000000..d401f55b2788
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.112.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= tests/cover tests/pytest tests/quality
+}
+
+src_install() {
+ local HAD_CLI=
+
+ distutils-r1_src_install
+
+ if [[ ! ${HAD_CLI} ]]; then
+ rm -r "${ED}/usr/bin" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install
+ if use cli && has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ HAD_CLI=1
+ else
+ rm -r "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}