summaryrefslogtreecommitdiff
path: root/dev-python/hypothesis
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest2
-rw-r--r--dev-python/hypothesis/hypothesis-6.108.2.ebuild103
2 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 6cf7b1d8573e..8f01571cac94 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,7 +1,9 @@
DIST hypothesis-6.104.1.gh.tar.gz 9466716 BLAKE2B 5ddefd5199bfb22ef8c2c2ae995de5353e7d067f044788f4cd9423cfa4674ff1c5a05760d686f4b4dd5fe9afb2b4ba1cdb38aa7d590575f79d75c460adde63ab SHA512 a9eef39e3cc8fde806cb860f47190239a680c3203ca0228450a7c999ee9618964e201c05a994835e5513f7945b3a5f830fd9fa941d4cfdf4793e5e2fb266df47
DIST hypothesis-6.107.0.gh.tar.gz 9470192 BLAKE2B 721d9ee1281600bca8387e396c1d79316db3130061ac40635f8cb8ba3cf91ad0417debe1276efb21cadf5e5f8ae856d13b82fc674313a21549adff645ce07b1f SHA512 13403073167d24e80fec4ed256a60e696b79b900a45dbd9f349b123fbefe3c7fa5daac6f35200d5198d4565033b65792cd1fd8a7816955aeddbbc0c7bb93d578
DIST hypothesis-6.108.0.gh.tar.gz 9472307 BLAKE2B 778c0c33b29fdf933d8321f0b5f0b7c14390ee5511da2290c398c47a9c787274430a3465ab0084aece7363112a7de2465bd1ab0e00984eca067ec672915079d0 SHA512 93b3028025a3c799a796b8781551b04d1eeb9ca41b924c17a275c394f25a552d33a0fd0fa28f24bf0d39eb8dc85d4af57979d9f3321b6901ddc0c56695deef5b
+DIST hypothesis-6.108.2.gh.tar.gz 9472513 BLAKE2B 1d3175fe390699e503d1341274461b5855cbfb934760ce47f53a546193ac71b66f06dbb8089c6af7a623a2cc6c62416f35851bb69ef49f13f622b7cefea37c6c SHA512 967b5f6372d5fd32aaf8258e03dca8d0f794908d34883295269ad271f8d0a89a5a433ba170d22a844d27c0145e74ee6c656577055b89aaa4e354955f93f5a55c
EBUILD hypothesis-6.104.1.ebuild 2585 BLAKE2B 1687b228255becec81edcbb2c7279a6a33ec75e18ac25e60e35a2aeed0ffccb3263da6de1b1a9950734d8f187df2d6892cfa33abe6dc4986936bfaf6feac80cf SHA512 69c9552dae1cc44bef13a844de12ce9e3e916fbab66610f2755d22ef7513b0d0ee50f5cbe22669a33528bd63acdd96fe52357a58c328921355ff5e3b79397b99
EBUILD hypothesis-6.107.0.ebuild 2593 BLAKE2B 434f71f7fad97f9e06d3e0a459d8d724c7000ea5ee8712f382c9c8f3746550159b272d208d926d389d87c8198452c410197e55a5e8cb5fec33c8a38719d6bf6f SHA512 5447fcdfaaaa7f15efa13eabee95232a4ac40c248ad5a3c9c7c26846e1868ac1ddd62bd3c6cd8375f7a5cb3ad322ee9dbd737699069ee7f1df2bcfcfcde84aa1
EBUILD hypothesis-6.108.0.ebuild 2593 BLAKE2B 434f71f7fad97f9e06d3e0a459d8d724c7000ea5ee8712f382c9c8f3746550159b272d208d926d389d87c8198452c410197e55a5e8cb5fec33c8a38719d6bf6f SHA512 5447fcdfaaaa7f15efa13eabee95232a4ac40c248ad5a3c9c7c26846e1868ac1ddd62bd3c6cd8375f7a5cb3ad322ee9dbd737699069ee7f1df2bcfcfcde84aa1
+EBUILD hypothesis-6.108.2.ebuild 2593 BLAKE2B 434f71f7fad97f9e06d3e0a459d8d724c7000ea5ee8712f382c9c8f3746550159b272d208d926d389d87c8198452c410197e55a5e8cb5fec33c8a38719d6bf6f SHA512 5447fcdfaaaa7f15efa13eabee95232a4ac40c248ad5a3c9c7c26846e1868ac1ddd62bd3c6cd8375f7a5cb3ad322ee9dbd737699069ee7f1df2bcfcfcde84aa1
MISC metadata.xml 492 BLAKE2B c9e9bbd59af55d1f47e5b7a86933c02b47f832122d03eaca56bd3ec9476cf260d91d4fd2da5068845d4525b7cc9f702b515e8d6a0dffa7923f5898cfd44e12a1 SHA512 166b33d6ac887f52d54fb9d556102038c00650a597d2de1c3aad3f8b5e136e9b6b7db31f05f3379435e4c5f943156d5839d78fc95461af411037a3162ea6705e
diff --git a/dev-python/hypothesis/hypothesis-6.108.2.ebuild b/dev-python/hypothesis/hypothesis-6.108.2.ebuild
new file mode 100644
index 000000000000..d401f55b2788
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.108.2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= tests/cover tests/pytest tests/quality
+}
+
+src_install() {
+ local HAD_CLI=
+
+ distutils-r1_src_install
+
+ if [[ ! ${HAD_CLI} ]]; then
+ rm -r "${ED}/usr/bin" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install
+ if use cli && has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ HAD_CLI=1
+ else
+ rm -r "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}