summaryrefslogtreecommitdiff
path: root/dev-python/hypothesis
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest2
-rw-r--r--dev-python/hypothesis/hypothesis-6.127.2.ebuild110
2 files changed, 112 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 2c860d45bd60..4541d94a8815 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,7 +1,9 @@
DIST hypothesis-6.125.2.gh.tar.gz 9508767 BLAKE2B 2f356f9678c1c8a56dcc66c5f96fee3426860e541e30c52b9108769fbb4112f9f4d8c77a9b9acef045a52749dd9325155fa8790c023f05dbf58608531ec0f89e SHA512 c953eef644a3c3239c2d0ace3eb6c02c7c48bb37d8fba6c6429720c7ab4b42fd76f6e42ee94f543db8d224bfb6912ed5e64feb181c24207a403e307364618843
DIST hypothesis-6.126.0.gh.tar.gz 9515798 BLAKE2B 8fbecef130bee50e856b4a3af9726d0bff759c1c8d69de9cff28387f87bc4aba72fc7b4944b9c1748c0b032de1556e197de5005ad193a61cc7d9f790f4975c5b SHA512 ee9e633c2f91c7d1a122515be0853c3aa9604db5ff79419c9ede646444c19d895b5cec8bb0dfed707b2b5a09c0899928643040c821e5b9dc47f46e19a18a0128
DIST hypothesis-6.127.1.gh.tar.gz 9518068 BLAKE2B 6cbc8aab8d2c952a7ab1ff9180f37e4acf6fb515899dbe1053ea474a6e4c1978a6fc928b94ee35ac12ed74581bf1b14869bffccb7e6564b1ab8578d025d8f710 SHA512 d77cfa4938779b0d6eda0c7a757f4b4dc23a199cc59eee89f59af90f1fa466f3b83ea1cd392ba0a88f1258ab08af77cae4d36afeccd0779707f82a8f9d1cca2f
+DIST hypothesis-6.127.2.gh.tar.gz 9518116 BLAKE2B 7a114549226f2bf85bbc211695575881db5b6d099075cb5ae0f076b1339b040ac942a6783721b717fee6cbf0dd404381f82e13779269547d971664758ca1ae37 SHA512 0cad6b5c00152bb67f81df1f00d6f3ba4d047cc0820e6b8a74031af42ed5baca3cf7cfaa53f988782d4ddb61e0465a1625a177dba4f8c46c66b1804ef389674f
EBUILD hypothesis-6.125.2.ebuild 2622 BLAKE2B df55cc343dec022a974b612e246553b8e99f95b445de919b38ff05839c0211e82703de7e52c2b86c348a34e740ab922edec47a04d66e8709ef31d6442daa937f SHA512 3e4c5188f836adac8679af690b621753b8f6f0e98f85837a26697b7d540598307c4e675044a557ec07240d6b46cb3f23791e77682bebf27d1a3a83f0b21590ab
EBUILD hypothesis-6.126.0.ebuild 2780 BLAKE2B 8ba5773e6c37903b4a7190eada0c9cfc98bd65b319db9d474e495386fab3d40c8f2ca47435b5a51ab6a3da1a11f016c54696aa6ac7e42691d9c15070e1af8075 SHA512 d9e0347c5ae910007e0f0baa1926460d81b6bc301f98b9251b16cd26ec7533640416549c9f53c254c22c270f8f5bfa940c086169261c9dfec435a2c7ddc96afc
EBUILD hypothesis-6.127.1.ebuild 2780 BLAKE2B 8ba5773e6c37903b4a7190eada0c9cfc98bd65b319db9d474e495386fab3d40c8f2ca47435b5a51ab6a3da1a11f016c54696aa6ac7e42691d9c15070e1af8075 SHA512 d9e0347c5ae910007e0f0baa1926460d81b6bc301f98b9251b16cd26ec7533640416549c9f53c254c22c270f8f5bfa940c086169261c9dfec435a2c7ddc96afc
+EBUILD hypothesis-6.127.2.ebuild 2780 BLAKE2B 8ba5773e6c37903b4a7190eada0c9cfc98bd65b319db9d474e495386fab3d40c8f2ca47435b5a51ab6a3da1a11f016c54696aa6ac7e42691d9c15070e1af8075 SHA512 d9e0347c5ae910007e0f0baa1926460d81b6bc301f98b9251b16cd26ec7533640416549c9f53c254c22c270f8f5bfa940c086169261c9dfec435a2c7ddc96afc
MISC metadata.xml 492 BLAKE2B c9e9bbd59af55d1f47e5b7a86933c02b47f832122d03eaca56bd3ec9476cf260d91d4fd2da5068845d4525b7cc9f702b515e8d6a0dffa7923f5898cfd44e12a1 SHA512 166b33d6ac887f52d54fb9d556102038c00650a597d2de1c3aad3f8b5e136e9b6b7db31f05f3379435e4c5f943156d5839d78fc95461af411037a3162ea6705e
diff --git a/dev-python/hypothesis/hypothesis-6.127.2.ebuild b/dev-python/hypothesis/hypothesis-6.127.2.ebuild
new file mode 100644
index 000000000000..5e0df5815a5e
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.127.2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3_11 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # TODO
+ 'hypothesis-python/tests/cover/test_reflection.py::test_clean_source[case-5]'
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -p rerunfailures --reruns=5 \
+ tests/cover tests/pytest tests/quality
+}
+
+src_install() {
+ local HAD_CLI=
+
+ distutils-r1_src_install
+
+ if [[ ! ${HAD_CLI} ]]; then
+ rm -r "${ED}/usr/bin" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install
+ if use cli && has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ HAD_CLI=1
+ else
+ rm -r "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}