summaryrefslogtreecommitdiff
path: root/dev-python/humanize/humanize-3.11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/humanize/humanize-3.11.0.ebuild')
-rw-r--r--dev-python/humanize/humanize-3.11.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/humanize/humanize-3.11.0.ebuild b/dev-python/humanize/humanize-3.11.0.ebuild
new file mode 100644
index 000000000000..ce3c080a882b
--- /dev/null
+++ b/dev-python/humanize/humanize-3.11.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest