summaryrefslogtreecommitdiff
path: root/dev-python/humanfriendly
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/humanfriendly')
-rw-r--r--dev-python/humanfriendly/Manifest2
-rw-r--r--dev-python/humanfriendly/humanfriendly-4.18.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/humanfriendly/Manifest b/dev-python/humanfriendly/Manifest
index fa47327f52ad..216196ad9332 100644
--- a/dev-python/humanfriendly/Manifest
+++ b/dev-python/humanfriendly/Manifest
@@ -1,3 +1,5 @@
DIST humanfriendly-4.17.tar.gz 344455 BLAKE2B 985ae142ea5378fcceb9f5f28773ac4dcaf0ea55ef1a7269fd1840a0b7119b54362aa93c330aa62e5424cc6f329e88717b45255c62b8e1d3f9ff5dd43a3c16c2 SHA512 a5786f28eaa0ff33919d9164ff30037fef5dbf60a31aece7679d1dddf3239f5a0d27209c710053cb0ac6779c1ef39102b1441fc620063283e90ef2ae11f8b621
+DIST humanfriendly-4.18.tar.gz 345853 BLAKE2B 9b03ea0679f787e216ee78efe8feb77f83562998813718845f4d21b7ce3f42cadff0e80b96f02da3cf6dc7f35cb0714f746940cf2ac0ec8e8981377989650c8a SHA512 01c7ee50d35154fe0b7ad39662ca6ff2dcd3e0f2a2eacc62f0184102c9db1c0fd99257273982aff56710b4e59024e8c20ee77ddd10c68e427c077ed4ca7e0022
EBUILD humanfriendly-4.17.ebuild 924 BLAKE2B c9606e6fa95529ea7e76a7db53a9daa9640cb4ba3ec1bc2d042081e4e5d263ae19693ac0ecce8de73d33896c46f6924cf3631785f39bc425fb23ab85c17a58d7 SHA512 5463f5b5b3a9ed07594cd70974cacff8237e68b66d8b591c498e9e87b975acebbb6aa343dbe3da27768d54f4ef1da2c910c0c67f27dddf9ab4121ed5f7655499
+EBUILD humanfriendly-4.18.ebuild 802 BLAKE2B 4b4e697c6a3e6093a4973076fcc80da382fd5045c48fe36a35610454e4893667e4593aef48c73e497e20c0ea806497373b382980377e7447ca05b3df3b57f448 SHA512 275ddb5f2b049f8cc4960832d7af37b6587171a2cad65ec7403f1b7e5832ca9ecf3d91e9e7e996fc0eeac6f7056440c57a9cb9e62dde5d760befa3c2517d70e1
MISC metadata.xml 326 BLAKE2B 5db2fb344393d914a42d1b9b256782d2e8286daa33ff4b8687d23e613ae8d168052dc310cab48ef0c49c524d3b5115d2a17cbede518fe93e944c0067c94f9c7b SHA512 1338df242248b37b4d016d8f9a31ffa004eed60a9122ed9ec8f94103271b3136b698a613c0f7c91411f43d96b136777e0ffe808c250f9ece3d29922312457f47
diff --git a/dev-python/humanfriendly/humanfriendly-4.18.ebuild b/dev-python/humanfriendly/humanfriendly-4.18.ebuild
new file mode 100644
index 000000000000..f7b4b4a45d9e
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-4.18.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.org/project/humanfriendly
+ https://github.com/xolox/python-humanfriendly
+ https://humanfriendly.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="test? ( dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/coloredlogs[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_test() {
+ pytest -vv ${PN}/tests.py || die "Tests fail with ${EPYTHON}"
+}