summaryrefslogtreecommitdiff
path: root/dev-python/httpx
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httpx')
-rw-r--r--dev-python/httpx/Manifest2
-rw-r--r--dev-python/httpx/httpx-0.19.0.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/httpx/Manifest b/dev-python/httpx/Manifest
index d43a074b2a47..a5edf40df00a 100644
--- a/dev-python/httpx/Manifest
+++ b/dev-python/httpx/Manifest
@@ -1,4 +1,6 @@
AUX httpx-0.18.2-big-endian.patch 2009 BLAKE2B 889f4636c88029778fc7f56b6635543794de81c60b3ef704e577a62ef8d8a1d3eccd19c80c3f6a9870f6b6aca98f4e3692e5ac31be800c707ad5bf91d73b6ece SHA512 3cc62f6b5a039f1c7c79854a95991e750162419d9c5f21a8fdf4d009f19a0694c711bec4aba7cfcfe17c08d98e8fabbe2ab4531ea58a4f5050867cf4f440c836
DIST httpx-0.18.2.tar.gz 1666756 BLAKE2B 3d1e25d503ae5306150c157bc83afdac9a475110d042e041b58de448a0dcfd75de3f4c15836b838dc799cd5f8b7e0d646e43bbe107ffad87d51ff016afe585cd SHA512 727974e5d5924fdd653987dd4f528d27bb2653085b01ef5efcdac39dc92ef2ed586f872c202349aa31105ad970cff914de4315c2d79338a6aa18bebb8126f392
+DIST httpx-0.19.0.tar.gz 1667455 BLAKE2B b8d4cb0b6e7f643b62b507930ccf1534d73d93261cab9281ef57d6392f00da325e897d5339aebacfa07aeae8278d3a81b78d6501a1587ffeaef68cc5087bfdaa SHA512 3b327f07d62cf0430672d4f1a4f884618e588496f049522de327f5c34f7260eb21739b7f1fbd6f43a21962bc8737547f3eddbc22751546647f56c9cd7212840a
EBUILD httpx-0.18.2.ebuild 1685 BLAKE2B 090ca06828527429791ca9f9a05a5ba585ead7c8653def22c18d3d83b555656f36f97e9dced4e94540eca083da0a10a8248ff710b768e9fec0a24d9a156f56c4 SHA512 9c9130ccf7927018c39a34dc9e9d8903c1132ddfb7805b68e7e5987a6384681c75e8a34181d5529860834c7b659b08d8966fd0371864d88974ffd3b07d15ed1d
+EBUILD httpx-0.19.0.ebuild 1641 BLAKE2B 6cf13505d6bfeae48533408a9ca0affc69878f4dba2eeae9075b96d078415575eee95eef54e4b91daaf8c2dc88417e1b1b57a132359aa5c68ffeb1ebf6a30a71 SHA512 3de4c68898b2b6ab881dfefdddacc827a28f775d51c6da83eebfa598b024c06633e06cb020b49c68537309376a8dab17b8a1c6ff0cf5a83411b53ee45a7e800a
MISC metadata.xml 444 BLAKE2B 62369fdf937f8caf46980620f2da0b16512ef94cbea9fecf0c336029a709e0975332d0d4e53ff4f3eeddeb9d231a5003dff9bbdf999846152bf578772b47d9a9 SHA512 bbbc7e622f0aae3b63e19765626ee13adf027d5ed98ca97fe04592b1f0a8da0cd0302b31f9cda90eaacf2bf5dad9c6472ddd795db75f0992ba4f084e4135ea3d
diff --git a/dev-python/httpx/httpx-0.19.0.ebuild b/dev-python/httpx/httpx-0.19.0.ebuild
new file mode 100644
index 000000000000..72dc4fb1f17f
--- /dev/null
+++ b/dev-python/httpx/httpx-0.19.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Docs builder mkdocs not keyworded on all these arches yet
+# DOCS_BUILDER="mkdocs"
+# DOCS_DEPEND="dev-python/mkdocs-material"
+# DOCS_AUTODOC=1
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 # docs
+
+DESCRIPTION="Fully-featured HTTP client which provides sync and async APIs"
+HOMEPAGE="https://www.python-httpx.org/"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/charset_normalizer[${PYTHON_USEDEP}]
+ dev-python/sniffio[${PYTHON_USEDEP}]
+ =dev-python/httpcore-0.13*[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.3[${PYTHON_USEDEP}]
+ <dev-python/rfc3986-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/hyper-h2[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/uvicorn[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # trio does not support py3.10
+ sed -i '/^import trio/d' tests/concurrency.py || die
+ sed -i '/pytest.param("trio", marks=pytest.mark.trio)/d' tests/conftest.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local deselect=(
+ # Internet
+ tests/client/test_proxies.py::test_async_proxy_close
+ tests/client/test_proxies.py::test_sync_proxy_close
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}