summaryrefslogtreecommitdiff
path: root/dev-python/httpcore
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest2
-rw-r--r--dev-python/httpcore/httpcore-1.0.5.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index d39956e8a852..f5e7726d0de8 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -1,3 +1,5 @@
DIST httpcore-1.0.4.gh.tar.gz 97682 BLAKE2B 2a500e63360095680b5b679856b8b2b9bdefc5f0a2d268ded83da52f0ef9cee5d09a99fa15565590d6c7ef4637146beeee3c950dd37a8a40f2af5189eb25cc4c SHA512 e618a562dbeb2229e9fdc8e63769415c7308614e120f24d0319e8fe9c96ed6de014fcc03ac376737c5791875bb82b2cc486247bfbf235afe11d48f09a2d2a701
+DIST httpcore-1.0.5.gh.tar.gz 97696 BLAKE2B 2e05f790e0e67c36f86ac1ee47eea716f820d68678eff63e73bce0f652448d782c66764e7f1ab3f8e891ebf2243b96ba79ca211ea769bbf5df117342e2942cbb SHA512 4b37f3874e65908598b906167d5b0840f66ffef95b65110d318d9e64df5fd23770a08ea44ea2f3cf6f9db50f20bb9fec99b40323b959675b37168414cf397bf8
EBUILD httpcore-1.0.4.ebuild 1221 BLAKE2B 240f2f97f5fa46b78e78afee39e4d6b9f51b8b767614d330ddbfbe402cf5109a5b63da5414d3b59016359f763aee403da5bc857d6f734d4cef577da3aeb507e8 SHA512 f52d5767df19583e9af721f9563f1958c0f1cf52ec177d6c42672e32a62dcd16ce1ecb5fcf786dfbecd1991f2f627f3d2a6d617b7efc90092ee9054c33a42d0c
+EBUILD httpcore-1.0.5.ebuild 1229 BLAKE2B bb9e98b602caa18bd7e3a22d1aabe802253132309e36c833dccb4b3d5085e22895d99a898928b738f3b7e72393b50484868a34bb68de4fb2371b7037445a8742 SHA512 6e714920745c9da8dd56532f94564879af7b9c5c7fdfc316ddcc486ecfec25454a87bdfba357828d43062cb8f7e0b71a921664647b510f5c1fa63dfca3d717a5
MISC metadata.xml 454 BLAKE2B f8a48d9ab81e5f74623dd0c8490e5de5cc711fda7f4614932e7ac6caa80bd23436037ddf9327d6bddc3d39c8b601b4ee74a85c0a10bacb20514cbf8278e34d1f SHA512 af962141bd55f51b27e0d4b61bcf7d5426e816df4f8c65be257d8fddd597664afe04e78ebe7e11caaebf06ae4fe17b88f568dc440403865ba6b8e3b47d796aa6
diff --git a/dev-python/httpcore/httpcore-1.0.5.ebuild b/dev-python/httpcore/httpcore-1.0.5.ebuild
new file mode 100644
index 000000000000..24a34134c031
--- /dev/null
+++ b/dev-python/httpcore/httpcore-1.0.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="
+ https://www.encode.io/httpcore/
+ https://github.com/encode/httpcore/
+ https://pypi.org/project/httpcore/
+"
+SRC_URI="
+ https://github.com/encode/httpcore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.15[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "SOCKS support" dev-python/socksio
+}