summaryrefslogtreecommitdiff
path: root/dev-python/hatch-nodejs-version
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hatch-nodejs-version')
-rw-r--r--dev-python/hatch-nodejs-version/Manifest3
-rw-r--r--dev-python/hatch-nodejs-version/hatch-nodejs-version-0.3.2.ebuild25
-rw-r--r--dev-python/hatch-nodejs-version/metadata.xml12
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/hatch-nodejs-version/Manifest b/dev-python/hatch-nodejs-version/Manifest
new file mode 100644
index 000000000000..9bd027672650
--- /dev/null
+++ b/dev-python/hatch-nodejs-version/Manifest
@@ -0,0 +1,3 @@
+DIST hatch_nodejs_version-0.3.2.tar.gz 16942 BLAKE2B dd68166a4aa7112dee4b566a748a40f951b73a4c7a8f6435ff0dd6706fed7d520d17d9e55604f9c901688a751d62f1160de3618026bdb829e5989fad87efa268 SHA512 e781669c84c3e61333cbd47f078ff6f16dae5b3c6e7d2ea76ae20ee78012ea9686a2be684127db821a6128408030bc09a0210386424f155af5a044f0178d44d4
+EBUILD hatch-nodejs-version-0.3.2.ebuild 553 BLAKE2B 567682e958e380ad9c94005279c5ad8b09fbb18353214f878b6a7360ca5cff00015bd5d1664a1525caae2931ac73b228c5c3ce9d772c46e38b41dc2fea231462 SHA512 64fda6b6a84d529da22e3e8073b23d07560ed8ffe8885df10737b5bccb9b3d157f5f36870a1bd97c5b1f764881b7f384f17faa2106e6aa39a074e5c5a511287a
+MISC metadata.xml 395 BLAKE2B e19ad65ca642ac5e29ff05d36678e971c309bc8ccb153da573b11ab62c765b65c0ebfd15cff615a229e58b420ee7bfbc1b1768784ab7cdcc3cc8ab63257bbb98 SHA512 990b25fece4c991b2b57dc535b81a4cbccae644e197dc0f6fe783b2a2542021d529541781e05512367e1d41b5632f3fdef255635e2ca6e646721000d5047da01
diff --git a/dev-python/hatch-nodejs-version/hatch-nodejs-version-0.3.2.ebuild b/dev-python/hatch-nodejs-version/hatch-nodejs-version-0.3.2.ebuild
new file mode 100644
index 000000000000..bd847cfad424
--- /dev/null
+++ b/dev-python/hatch-nodejs-version/hatch-nodejs-version-0.3.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Hatch plugin for versioning from a package.json file"
+HOMEPAGE="
+ https://github.com/agoose77/hatch-nodejs-version/
+ https://pypi.org/project/hatch-nodejs-version/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/hatchling-0.21.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/hatch-nodejs-version/metadata.xml b/dev-python/hatch-nodejs-version/metadata.xml
new file mode 100644
index 000000000000..400fe916bf3d
--- /dev/null
+++ b/dev-python/hatch-nodejs-version/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">agoose77/hatch-nodejs-version</remote-id>
+ <remote-id type="pypi">hatch-nodejs-version</remote-id>
+ </upstream>
+</pkgmetadata>