summaryrefslogtreecommitdiff
path: root/dev-python/happydoc
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/happydoc')
-rw-r--r--dev-python/happydoc/Manifest5
-rw-r--r--dev-python/happydoc/files/happydoc-3.1-python-2.6.patch28
-rw-r--r--dev-python/happydoc/files/happydoc-3.1-setup.py158
-rw-r--r--dev-python/happydoc/happydoc-3.1-r2.ebuild39
-rw-r--r--dev-python/happydoc/metadata.xml11
5 files changed, 0 insertions, 241 deletions
diff --git a/dev-python/happydoc/Manifest b/dev-python/happydoc/Manifest
deleted file mode 100644
index 8c38ae4ff3d8..000000000000
--- a/dev-python/happydoc/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX happydoc-3.1-python-2.6.patch 726 BLAKE2B 15cf7457474d5314aa51fedd435c35f8985c75760845615de37184602da5878e7d8a1e8c6e17bd36e36b3ddad410a8347975443bfe5759e0055273e31e213bd8 SHA512 b47a45271cdf0e26167562302d82eac8198b3dcb74cbb6315ba24b0ac3eb66a5a78bff3259b926528cde8d78d42480b1ff1930e7d27fdd1a67f9824beccef8b1
-AUX happydoc-3.1-setup.py 4899 BLAKE2B cbd6b098150362a603143c52d6190eae1d12172189b93dccf8fac9d0df264326b70f68098f9da6244e41b4da664e5c088f7ff3d6f680ed9b03220ce9ee0a1549 SHA512 536f165b37a6508e1d364184474e69ed410c56bd7936bbbf041d1541af41414b156b5f079c39917b12fb82f377ae52dcf50c7a3d260e911a6d0bb38950d39469
-DIST HappyDoc_r3_1.tar.gz 732849 BLAKE2B f5e77215fed9b188672458ae9be6d96f5332bf5e2897b202516bb706cd5aaacd25a51aec4e5921b9ba8899ad4a38e08f9edd9346cd00cc8abccb95db179c23d9 SHA512 5f526f90225f189f59fdca24b3db1cd73c7346b859cc3b8a00ddaf248c2e0901ad048c1a83ec1b9ee3f950f1260427b0fd1d6f4b1e6c4b772615f6ca799f86ff
-EBUILD happydoc-3.1-r2.ebuild 1031 BLAKE2B 8cde458b99e5ae28d4c717968c1695d33de5ee4d8f0f0e1ec54ddd6928677dd3312134cf9863a4162aab88644324152650755e58fc6775417c2648f6cafd1add SHA512 31a40af952be0b89883aa8838e4f02cd150021cc27f0c6fed51c893f6f127e86d99a618ef3a28dafb26762f24f7358a4ce936996c13a6e9e823b258d1a728272
-MISC metadata.xml 318 BLAKE2B 61a8e30c9e34e77e6888037ac00b669e9e786c0b5c8dcf7bb2c709dac8e4f4dff2a5e9fd3527fcbdeac9baa8129e87cb9653f677c5f16620e71c949fb977e65e SHA512 9b9ddb517c3bcdd431de07987594db7d7ca25f5cce3550f35c9731dbd72ef5301330c97138dee8bdf369c55b219bb4da71048419c5cfc2f15f7ba1e174b3eb43
diff --git a/dev-python/happydoc/files/happydoc-3.1-python-2.6.patch b/dev-python/happydoc/files/happydoc-3.1-python-2.6.patch
deleted file mode 100644
index 4cced8e25833..000000000000
--- a/dev-python/happydoc/files/happydoc-3.1-python-2.6.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- happydoclib/CommandLineApp.py
-+++ happydoclib/CommandLineApp.py
-@@ -102,10 +102,21 @@
- #
- # Exception names
- #
-- ReservedOptionName = 'Reserved option name'
-- HelpRequested='Help requested'
-- InvalidOptionValue='Invalid value for option'
-- InvalidArgument='Invalid argument to program'
-+ class ReservedOptionName(ValueError):
-+ 'Reserved option name'
-+ pass
-+
-+ class HelpRequested(ValueError):
-+ 'Help requested'
-+ pass
-+
-+ class InvalidOptionValue(ValueError):
-+ 'Invalid value for option'
-+ pass
-+
-+ class InvalidArgument(ValueError):
-+ 'Invalid argument to program'
-+ pass
-
- #
- # Globally useful configuration stuff.
diff --git a/dev-python/happydoc/files/happydoc-3.1-setup.py b/dev-python/happydoc/files/happydoc-3.1-setup.py
deleted file mode 100644
index 40ea5d6cd25f..000000000000
--- a/dev-python/happydoc/files/happydoc-3.1-setup.py
+++ /dev/null
@@ -1,158 +0,0 @@
-#!/usr/bin/env python
-#
-# $Id: setup.py,v 1.11 2002/02/05 19:59:36 doughellmann Exp $
-#
-# Time-stamp: <02/02/05 10:00:12 dhellmann>
-#
-# Copyright 2001 Doug Hellmann.
-#
-#
-# All Rights Reserved
-#
-# Permission to use, copy, modify, and distribute this software and
-# its documentation for any purpose and without fee is hereby
-# granted, provided that the above copyright notice appear in all
-# copies and that both that copyright notice and this permission
-# notice appear in supporting documentation, and that the name of Doug
-# Hellmann not be used in advertising or publicity pertaining to
-# distribution of the software without specific, written prior
-# permission.
-#
-# DOUG HELLMANN DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
-# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
-# NO EVENT SHALL DOUG HELLMANN BE LIABLE FOR ANY SPECIAL, INDIRECT OR
-# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
-# OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
-# NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
-# CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
-#
-"""Distutils setup file for HappyDoc
-
-"""
-
-__rcs_info__ = {
- #
- # Creation Information
- #
- 'module_name' : '$RCSfile: happydoc-3.1-setup.py,v $',
- 'rcs_id' : '$Id$',
- 'creator' : 'Doug Hellmann <doug@hellfly.net>',
- 'project' : 'HappyDoc',
- 'created' : 'Sat, 03-Feb-2001 12:51:26 EST',
-
- #
- # Current Information
- #
- 'author' : '$Author: neurogeek $',
- 'version' : '$Revision: 1.1 $',
- 'date' : '$Date: 2009/02/25 20:59:36 $',
-}
-try:
- __version__ = __rcs_info__['version'].split(' ')[1]
-except:
- __version__ = '0.0'
-
-#
-# Import system modules
-#
-from distutils.core import setup
-import string
-import sys
-
-#
-# Import Local modules
-#
-
-#
-# Module
-#
-
-BSD_LICENSE="""
-
- Copyright 2001, 2002 Doug Hellmann.
-
- All Rights Reserved
-
-Permission to use, copy, modify, and distribute this software and
-its documentation for any purpose and without fee is hereby
-granted, provided that the above copyright notice appear in all
-copies and that both that copyright notice and this permission
-notice appear in supporting documentation, and that the name of Doug
-Hellmann not be used in advertising or publicity pertaining to
-distribution of the software without specific, written prior
-permission.
-
-DOUG HELLMANN DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
-INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
-NO EVENT SHALL DOUG HELLMANN BE LIABLE FOR ANY SPECIAL, INDIRECT OR
-CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
-OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
-NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
-CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
-"""
-
-LONG_DESCRIPTION = """
- HappyDoc is a tool for extracting documentation from Python source
- code. It differs from other such applications by the fact that it
- uses the parse tree for a module to derive the information used in
- its output, rather that importing the module directly. This allows
- the user to generate documentation for modules which need special
- context to be imported.
-"""
-
-
-def cvsProductVersion(cvsVersionString='$Name: $'):
- """Function to return the version number of the program.
-
- The value is taken from the CVS tag, assuming the tag has the form:
-
- rX_Y_Z
-
- Where X is the major version number, Y is the minor version
- number, and Z is the optional sub-minor version number.
- """
- cvs_version_parts=string.split(cvsVersionString)
- if len(cvs_version_parts) >= 3:
- app_version = string.strip(cvs_version_parts[1]).replace('_', '.')
- if app_version and app_version[0] == 'r':
- app_version = app_version[1:]
- else:
- app_version = 'WORKING'
- return app_version
-
-
-
-if sys.platform == 'win32':
- platform_specific_scripts = ['happydocwin.py']
-else:
- platform_specific_scripts = ['happydoc']
-
-setup (
- name = 'HappyDoc',
- version = cvsProductVersion(),
-
- description = 'HappyDoc Automatic Documentation System',
- long_description = LONG_DESCRIPTION,
-
- author = 'Doug Hellmann',
- author_email = 'doug@hellfly.net',
-
- url = 'http://happydoc.sourceforge.net',
- licence = BSD_LICENSE,
-
- platforms = ('Any',),
- keywords = ('documentation', 'extraction', 'source', 'docstring', '__doc__'),
-
- packages = [ 'happydoclib',
- 'happydoclib.docset',
- 'happydoclib.docstring',
- 'happydoclib.docstring.StructuredText',
- 'happydoclib.parseinfo',
- 'happydoclib.parsers',
- ],
-
- package_dir = { '': '.' },
-
- scripts = platform_specific_scripts,
- )
-
diff --git a/dev-python/happydoc/happydoc-3.1-r2.ebuild b/dev-python/happydoc/happydoc-3.1-r2.ebuild
deleted file mode 100644
index 1b3cfd122e31..000000000000
--- a/dev-python/happydoc/happydoc-3.1-r2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1 versionator
-
-MY_PN="HappyDoc"
-MY_PV=$(replace_all_version_separators "_" ${PV})
-MY_V=$(get_major_version ${PV})
-
-DESCRIPTION="Tool for extracting documentation from Python source code"
-HOMEPAGE="http://happydoc.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}_r${MY_PV}.tar.gz"
-
-LICENSE="HPND ZPL"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc sparc x86"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-# Tests need extra data not present in the release tarball.
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_PN}${MY_V}-r${MY_PV}"
-
-python_prepare_all() {
- cp "${FILESDIR}/${P}-setup.py" setup.py || die "Copying of setup.py failed"
- epatch "${FILESDIR}/${P}-python-2.6.patch"
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( srcdocs/${MY_PN}${MY_V}-r${MY_PV}/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/happydoc/metadata.xml b/dev-python/happydoc/metadata.xml
deleted file mode 100644
index 2d122c86dfd5..000000000000
--- a/dev-python/happydoc/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">happydoc</remote-id>
- </upstream>
-</pkgmetadata>