summaryrefslogtreecommitdiff
path: root/dev-python/h2/h2-4.1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/h2/h2-4.1.0-r1.ebuild')
-rw-r--r--dev-python/h2/h2-4.1.0-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/h2/h2-4.1.0-r1.ebuild b/dev-python/h2/h2-4.1.0-r1.ebuild
index f04351c78eca..7dee9b75abc0 100644
--- a/dev-python/h2/h2-4.1.0-r1.ebuild
+++ b/dev-python/h2/h2-4.1.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1
@@ -32,6 +32,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${P}-python3.11-tests.patch
+)
+
distutils_enable_tests pytest
python_test() {