summaryrefslogtreecommitdiff
path: root/dev-python/gst-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/Manifest2
-rw-r--r--dev-python/gst-python/gst-python-1.22.12.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/gst-python/Manifest b/dev-python/gst-python/Manifest
index e913773d257a..b2f67a2d26c7 100644
--- a/dev-python/gst-python/Manifest
+++ b/dev-python/gst-python/Manifest
@@ -1,3 +1,5 @@
DIST gst-python-1.22.11.tar.xz 118072 BLAKE2B 7133bdc6462ed54669b18f0650ec9e9d5c90d406eadedccc2f125c01b05366c8cfd89ae17178a8197fd4c251d53fd848bdb498ff377076e402983a404f16c186 SHA512 749a3080ad56edfee66c6f24ab106b07cd2a7d6e5f704147a69e12fc0a1da9d9b8d8337c36ce62af459577df3f0804c60cbeb4a211454277ad0a46fd89edcfa5
+DIST gst-python-1.22.12.tar.xz 118924 BLAKE2B 0d31f86e2b2e673da545c94f7f4b5f934614d4cf906b96844fbfecb0cf8d6af3d85fbf197477d534f2d72248e048b945c4b974b5239e4ae68951428e016526e3 SHA512 27cd724a21d66a6c3827e3cbaeeb70f15af5253763c1410990232cb550a363a7c61ff076771fdad94f31026ad70b051d2b1ef180bbab92e2e456ae4ce467223f
EBUILD gst-python-1.22.11.ebuild 1620 BLAKE2B ac56941027da786ab498bd6ea94cb6196bc03bfec5654d3932b25ba0eda6edb7d70c3557f6d64241ded7ec48b1a34893f46b9321d18f669b4f84a7165399a30d SHA512 6d331868532c31f611c4079047c0e593e0f2eeca463718263286cb11f41134d27cc57281e0e780458e0805457b2faec162a9ad3509724d0eeaa92199e35fc4b6
+EBUILD gst-python-1.22.12.ebuild 1626 BLAKE2B 7b1b61db8b57f57af9d0a1d7e64e6bf3509702bf82b8e01e1570fd42619597d649f80ef135d5f1fc28315e9d6758dbe596413b87231e42eff7dc6130717b1452 SHA512 a0449c9076a1ddaac966016b46358b9a0aa8c039c5e0fa40aac96baed73c3cc66216d2e1e6776ad329aebe8b1da7e5813856502407bb06da8168f12523d102da
MISC metadata.xml 267 BLAKE2B 331be70b2fa90cce1bf91ded1dac141de6a9bec40c1736bcb90d280ac7fabf22cfd0a701c7fd5864f007d1159954f7ee55701d5e68b47a1a9a217ca34b7ee619 SHA512 4dcdd6bc6d148a0e02a0f1b766bd0c5712d373d898c06078d8630e0067e858b815117392a11332b257156e95da6337494d99c2724d24cadb97432089908644b5
diff --git a/dev-python/gst-python/gst-python-1.22.12.ebuild b/dev-python/gst-python/gst-python-1.22.12.ebuild
new file mode 100644
index 000000000000..50e860486672
--- /dev/null
+++ b/dev-python/gst-python/gst-python-1.22.12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit meson python-r1 xdg-utils
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=media-libs/gstreamer-${PV}:1.0[introspection]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Avoid building & testing plugin - it must NOT be multi-python as gst-inspect will map in all libpython.so versions and crash or behave mysteriously.
+ # Python plugin support is of limited use (GIL gets in the way). If it's ever requested or needed, it should be a
+ # separate python-single-r1 media-plugins/gst-plugins-python package that only builds the plugin directory.
+ sed -e '/subdir.*plugin/d' -i meson.build || die
+ sed -e '/test_plugin.py/d' -i testsuite/meson.build || die
+
+ xdg_environment_reset
+}
+
+src_configure() {
+ configuring() {
+ meson_src_configure \
+ -Dpython="${EPYTHON}"
+ }
+ python_foreach_impl configuring
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ python_foreach_impl meson_src_test
+}
+
+src_install() {
+ installing() {
+ meson_src_install
+ python_optimize
+ }
+ python_foreach_impl installing
+}