summaryrefslogtreecommitdiff
path: root/dev-python/gsd/gsd-1.5.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gsd/gsd-1.5.3-r1.ebuild')
-rw-r--r--dev-python/gsd/gsd-1.5.3-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/gsd/gsd-1.5.3-r1.ebuild b/dev-python/gsd/gsd-1.5.3-r1.ebuild
new file mode 100644
index 000000000000..caac808feb22
--- /dev/null
+++ b/dev-python/gsd/gsd-1.5.3-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="https://bitbucket.org/glotzer/gsd"
+SRC_URI="https://glotzerlab.engin.umich.edu/Downloads/${PN}/${PN}-v${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}"
+
+S="${WORKDIR}/${PN}-v${PV}"