summaryrefslogtreecommitdiff
path: root/dev-python/graphviz/graphviz-0.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/graphviz/graphviz-0.16.ebuild')
-rw-r--r--dev-python/graphviz/graphviz-0.16.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/graphviz/graphviz-0.16.ebuild b/dev-python/graphviz/graphviz-0.16.ebuild
new file mode 100644
index 000000000000..4af9d661d0e2
--- /dev/null
+++ b/dev-python/graphviz/graphviz-0.16.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="https://graphviz.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="media-gfx/graphviz"
+BDEPEND="
+ app-arch/unzip
+ test? ( ${RDEPEND}
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
+ media-gfx/graphviz[gts,pdf]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cov --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
+}