summaryrefslogtreecommitdiff
path: root/dev-python/graphviz/graphviz-0.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/graphviz/graphviz-0.13.ebuild')
-rw-r--r--dev-python/graphviz/graphviz-0.13.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/graphviz/graphviz-0.13.ebuild b/dev-python/graphviz/graphviz-0.13.ebuild
new file mode 100644
index 000000000000..15f6ec7d3687
--- /dev/null
+++ b/dev-python/graphviz/graphviz-0.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="https://graphviz.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="media-gfx/graphviz"
+DEPEND="
+ app-arch/unzip
+ test? ( ${RDEPEND}
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ py.test -v || die
+}