summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.161.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 638abc39ca90..b4438dda169f 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,5 +1,7 @@
DIST google_api_python_client-2.159.0.tar.gz 12302576 BLAKE2B a4cf681694930b303aab3a1756fee9af2bbd52258fa6ce3a3ede3db0a211467b0ad3a8d4d75e756d66d08ee5d5b58d799136ebc6d4e739bb9e655fbf6ca24eae SHA512 57295f7a9d651466760cfb69c61e52478951da083c4c7a2238d1b0e55860cbe9d1f6d76c9b89acf36bfa39beac28c8594f96c4ecfeb04f174474d259434c32e5
DIST google_api_python_client-2.160.0.tar.gz 12304236 BLAKE2B 572e12ea6d7e496b7d84646ddff48fc0656681fdd7efa54410efaa8a0a5a4cfa4171d7816c5127c951b46f2b7eaf97df9e586618a504b4d0a9f7b72c25165250 SHA512 1a232b3b840f71348f38d9587696c2795e88fdfead3a77db8725f59d0e263d0864d1143b6421bc8a364f19129e00770ef2143153a44d1b8c1266844b1f2f565a
+DIST google_api_python_client-2.161.0.tar.gz 12358839 BLAKE2B b7537f29c078adc2a2a0b89da52acc9fe53db4ecae742f367019ef780951d668f8ff7e6390fd417644bdae2ab97f472b99f3472d642382b3341f5894de477cad SHA512 19fd8cf49d96fba19381a9ca891ee53cf521ff9fb3103c6f1f22207ab6e7d0dd0de445d5f96d9d6a7d464139a9c38052bdaf4878fbacf9d64fa97006f1ea6da5
EBUILD google-api-python-client-2.159.0.ebuild 1455 BLAKE2B 753e47ac06d5790f890e4e5c8b50f2ecbaa6ec0c6b51ee4dd8ac472c927fd60cc47f0458304325ef91bfd110d9af4bc5f89365e6949cc62243e5bf112f0591e9 SHA512 ffb14b186d2976c3af821bf9b34218eebf26271b8730e7e55e7c8f8f182a1944569da43fe831c8e6639b3f82ad833d3dc1c4290f95f3ac553c24c74b8e13eb28
EBUILD google-api-python-client-2.160.0.ebuild 1458 BLAKE2B abc96ed5fc57035f36cdf6723758169539e99033baac0226f9d02b91417806bab2fced58aae6fa0c9530b787375c16ff6bf92145e325ed96d3f7124c34986924 SHA512 b3a9f6c444f98007488fbd795ae9adc9aaf16d51dcd761527aa819385840ee1c4a0bdb76f36e896f841c1e0203e0f1c406582f98c2e38c072ab1f9e8efdaf9bb
+EBUILD google-api-python-client-2.161.0.ebuild 1458 BLAKE2B abc96ed5fc57035f36cdf6723758169539e99033baac0226f9d02b91417806bab2fced58aae6fa0c9530b787375c16ff6bf92145e325ed96d3f7124c34986924 SHA512 b3a9f6c444f98007488fbd795ae9adc9aaf16d51dcd761527aa819385840ee1c4a0bdb76f36e896f841c1e0203e0f1c406582f98c2e38c072ab1f9e8efdaf9bb
MISC metadata.xml 538 BLAKE2B bf0b8ab3a89ce9ab1d2159f4c0ebfe3f2646aced20bd2006485510c12d22e83cc130fac979f699ae6431a610c8d2acf86c04b39bc262abaf167c20571a860810 SHA512 30d004d944055660165954f8475e57ba45cef56423c80a324118836d78e5376261409955155a40c9bd988f230f3e2fc44c6aeb6fae3028c78c55a382ccd83bff
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.161.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.161.0.ebuild
new file mode 100644
index 000000000000..f4f4a9c95e9b
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.161.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
+ tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
+ )
+
+ epytest tests
+}