summaryrefslogtreecommitdiff
path: root/dev-python/gnuplot-py/gnuplot-py-1.8-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gnuplot-py/gnuplot-py-1.8-r2.ebuild')
-rw-r--r--dev-python/gnuplot-py/gnuplot-py-1.8-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/gnuplot-py/gnuplot-py-1.8-r2.ebuild b/dev-python/gnuplot-py/gnuplot-py-1.8-r2.ebuild
new file mode 100644
index 000000000000..921b7992021f
--- /dev/null
+++ b/dev-python/gnuplot-py/gnuplot-py-1.8-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_SINGLE_IMPL=true
+
+inherit distutils-r1
+
+DESCRIPTION="A python wrapper for Gnuplot"
+HOMEPAGE="http://gnuplot-py.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ppc64 ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="
+ || (
+ dev-python/numpy-python2[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${DEPEND}
+ sci-visualization/gnuplot"
+
+DOCS=( ANNOUNCE.txt CREDITS.txt FAQ.txt NEWS.txt TODO.txt )
+
+PATCHES=( "${FILESDIR}"/${PN}-1.7-mousesupport.patch )
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/Gnuplot/. )
+ distutils-r1_python_install_all
+}
+# testsuite does NOT run unattended, so left out here