summaryrefslogtreecommitdiff
path: root/dev-python/glance_store/glance_store-0.18.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/glance_store/glance_store-0.18.0.ebuild')
-rw-r--r--dev-python/glance_store/glance_store-0.18.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/glance_store/glance_store-0.18.0.ebuild b/dev-python/glance_store/glance_store-0.18.0.ebuild
deleted file mode 100644
index 201407baf74b..000000000000
--- a/dev-python/glance_store/glance_store-0.18.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
-
-inherit distutils-r1
-
-DESCRIPTION="A library for glance"
-HOMEPAGE="https://github.com/openstack/glance_store"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="+cinder"
-
-CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-concurrency-3.8.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.16.0[${PYTHON_USEDEP}]
- virtual/python-enum34[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
- <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/python-keystoneclient-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/python-keystoneclient-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
- cinder? ( >=dev-python/python-cinderclient-1.2.1[${PYTHON_USEDEP}] )
-"
-
-python_prepare_all() {
- sed -i '/ordereddict/d' requirements.txt
- distutils-r1_python_prepare_all
-}