summaryrefslogtreecommitdiff
path: root/dev-python/geventhttpclient
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/geventhttpclient')
-rw-r--r--dev-python/geventhttpclient/Manifest2
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-1.5.1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/geventhttpclient/Manifest b/dev-python/geventhttpclient/Manifest
index 30be977deeac..71ae848a09eb 100644
--- a/dev-python/geventhttpclient/Manifest
+++ b/dev-python/geventhttpclient/Manifest
@@ -1,3 +1,5 @@
DIST geventhttpclient-1.4.5.tar.gz 58183 BLAKE2B 48d44048e7040552824ed19ac49c6dda41536ffded56bae0d942c06f111a327a1d571872f35f388853b479ea1aaa6de518f86e7ee72e362360492530ade65131 SHA512 9ffe00c79b145dab104e1dce336e072060f315d9bee880daf64b5f1f52e661d810dab9a60286320a7d30cf0e794465f201c039cc31fe7ec325cdb3a8350c9f7d
+DIST geventhttpclient-1.5.1.tar.gz 58398 BLAKE2B 9995e14c635b06f729d342b19187d4c4b935f903038950fc05e8d9260a341d3a551750c1cd46798ac2d97603d1dba449d4db3a51a44e49a1720ec23b1526edf8 SHA512 46fa5333149b86f5c4b5d06adfe5d49402d0220266c27507da1645f1da8a50562e142e37435a029bb4184c417e8a4123301a7dfc8769ce419e841afebc11247c
EBUILD geventhttpclient-1.4.5.ebuild 1477 BLAKE2B 35bfeb29334f743c0bd7ee2ed476f51c056606f14caeaa149ea4d0cae6e66a5868b804528fc60cc542b07474b5598f30e6b007985255e1bc9b2798ab0497cb91 SHA512 68b9ef7dd73a8aa1da5fff02fec0edbce304bd0d3c26dc1be96f06ec3cce39f16a98e636673034d78cbead3a578c7a81fe1350876908bfdf0c23543147813fcf
+EBUILD geventhttpclient-1.5.1.ebuild 1491 BLAKE2B 1f31f42a9b960abdecd37fddce4fbe7bd40c6def9e09e01c279d38df18cd4967a00e235a743c575d387e9c8d353024cff6f0a5f132b394d59ed82abbc7c97602 SHA512 a020482da4732d2fb91d0a22928236b906af6edf8a35a4744f2b08d1031bdcd5f079425723b6864645a66df771ecf26af7be2ae1dd4db1e42bc095131d21048a
MISC metadata.xml 555 BLAKE2B a747ad2f270f2267b197d8489d253c18bc6093063f9cbc037afa0598931a244aa9da1d0d9d5c8e69a98c4f1fdfb8275917b9493dec895db5225a8918c51d0f43 SHA512 61c8affec2fd6d68f40d721842d7a121f6e24fdad560d131acf9e8b0f1a229afd2580fe9f78095da9a77b8dd9accf72b180eef797c4e143776e8beb7b7c36fcc
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.5.1.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.5.1.ebuild
new file mode 100644
index 000000000000..6595b2fc1c19
--- /dev/null
+++ b/dev-python/geventhttpclient/geventhttpclient-1.5.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
+HOMEPAGE="https://github.com/gwik/geventhttpclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/gevent[events,${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Avoid ModuleNotFoundError for tests we skip later
+ sed -i '/^import dpkt.ssl/d' src/geventhttpclient/tests/test_ssl.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # These SNI tests require dpkt which is not in the tree
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
+ )
+ # Append to sys.path to avoid ImportError
+ # https://bugs.gentoo.org/667758
+ # Skip tests which require internet access
+ epytest --import-mode=append -m "not online"
+}