summaryrefslogtreecommitdiff
path: root/dev-python/geoalchemy2
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/geoalchemy2')
-rw-r--r--dev-python/geoalchemy2/Manifest3
-rw-r--r--dev-python/geoalchemy2/geoalchemy2-0.3.ebuild32
-rw-r--r--dev-python/geoalchemy2/metadata.xml12
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/geoalchemy2/Manifest b/dev-python/geoalchemy2/Manifest
new file mode 100644
index 000000000000..1604a50e0106
--- /dev/null
+++ b/dev-python/geoalchemy2/Manifest
@@ -0,0 +1,3 @@
+DIST geoalchemy2-0.3.tar.gz 93256 BLAKE2B 4d33ad8b1211f2c23da7ccb8945a051bcb58a1c4963f3c45ba4d20d26658bf0cfa983edd256aebf9ee86a768c7745f21230ba199437bff514d720da7aebc640b SHA512 5f94f6459eba1266c3b31b6d0b1f16478c1641a29b3dbe26cfdc3983d3aa5642b075871fb4722e6bccca7d1960ac1d87103351d846a061891f17d407df4867c8
+EBUILD geoalchemy2-0.3.ebuild 796 BLAKE2B 595e204fd8055e8ba9824581a7b11092e4c3ac1bcac9cf81648830d3be499045aefaf2626d23619d305119aeee788fb66b1bd41344d973074d290bbf0202da02 SHA512 a99b38ae58724484d1bbc1271fb25e3c3b903d164dfd7e3612873f2cd57f69fdf8aca3c1c456f8dad3099f5ca06a398a7bea723d17d599a2f90ce6b010a30403
+MISC metadata.xml 388 BLAKE2B aae7ecb5090864e223172cb34f0ddbd114be20417c40f932a5c354804ee049a637eca182b9e33e564f60e7e6eae502c73cff77644dea4ad4498ce89c6938a54b SHA512 fe5d16f1006eea8b0eead7381650b7a06f547dde06224daede90460e2319b8c3f5eb527125f1004d56d866587003aafc35c0c17518699617798d5d05b3fbd254
diff --git a/dev-python/geoalchemy2/geoalchemy2-0.3.ebuild b/dev-python/geoalchemy2/geoalchemy2-0.3.ebuild
new file mode 100644
index 000000000000..6c5e628f7fa5
--- /dev/null
+++ b/dev-python/geoalchemy2/geoalchemy2-0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Geospatial extension to SQLAlchemy with PostGIS support"
+HOMEPAGE="https://geoalchemy-2.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/geoalchemy/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# ^^ tarball on pypi is missing tests
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/sqlalchemy-0.8[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ sci-libs/Shapely[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+RESTRICT="test"
+# tests require a running PostgreSQL database
+
+python_test() {
+ py.test tests || die
+}
diff --git a/dev-python/geoalchemy2/metadata.xml b/dev-python/geoalchemy2/metadata.xml
new file mode 100644
index 000000000000..9ef773e0fe0d
--- /dev/null
+++ b/dev-python/geoalchemy2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">GeoAlchemy2</remote-id>
+ <remote-id type="github">geoalchemy/geoalchemy2</remote-id>
+ </upstream>
+</pkgmetadata>