summaryrefslogtreecommitdiff
path: root/dev-python/futures/futures-3.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/futures/futures-3.0.3.ebuild')
-rw-r--r--dev-python/futures/futures-3.0.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/futures/futures-3.0.3.ebuild b/dev-python/futures/futures-3.0.3.ebuild
new file mode 100644
index 000000000000..1405b9a27043
--- /dev/null
+++ b/dev-python/futures/futures-3.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+inherit distutils-r1
+
+DESCRIPTION="Backport of the concurrent.futures package from Python 3.2"
+HOMEPAGE="https://code.google.com/p/pythonfutures https://pypi.python.org/pypi/futures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # tests that fail under pypy
+ # https://code.google.com/p/pythonfutures/issues/detail?id=27
+ if [[ "${EPYTHON}" == pypy ]]; then
+ sed -e 's:test_del_shutdown:_&:g' \
+ -e 's:test_repr:_&:' -i test_futures.py || die
+ fi
+ "${PYTHON}" test_futures.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGES )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}