summaryrefslogtreecommitdiff
path: root/dev-python/furo
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/furo')
-rw-r--r--dev-python/furo/Manifest2
-rw-r--r--dev-python/furo/furo-2024.8.6.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/furo/Manifest b/dev-python/furo/Manifest
index a5d184109e36..088ace2c2450 100644
--- a/dev-python/furo/Manifest
+++ b/dev-python/furo/Manifest
@@ -1,3 +1,5 @@
DIST furo-2024.7.18-py3-none-any.whl 340824 BLAKE2B 619e7183541921ec31f5a7e7ebcbc86f0507e04bf7e5c9e308a3b6a6b580cf734fe46b641b3bcaaeeaba39516ca27b49ef8faadd0d9d5864343aafc15a05037d SHA512 62c047742a0a851e5faf56013751d05a411920ca7659ef42fc06bcce6766a6605734b370a636f4b1c2805def42881c273a2b5eb6704484571d76a44145b0a346
+DIST furo-2024.8.6-py3-none-any.whl 341333 BLAKE2B e0cf87a69b35a0a48eb54eb9530ec92f5fa06882b4c4a9bf306a3b1eee7af8510e37dfd1b612fe747856e48eada1eed05ae8e5e270616bf9b5fd5a70705a9c53 SHA512 e9e32eb26659b710836c86bd881c07625d14a10000674d488da2dc71e5cbb7ba6ce4494892f731dbcf288af11bcf6870f9f97f70364425cca4a00f7edda01d48
EBUILD furo-2024.7.18.ebuild 1018 BLAKE2B 171ea646e3284a3bc7419a1405ffbd8a4e87505f5a54452c4eed2c9ece8ee6d88cd70dea2c08575f7e42d446aa3d63643d1723996f5d41e935fc34f93c28a5a5 SHA512 8f924908e923b6520d158835549ee9e442489ed1f3ad2f311b83ba38659b2c2dc82da464b69da1f8afd45bf245b20bbe73f4af012f9746310377c6a35e05a29e
+EBUILD furo-2024.8.6.ebuild 1026 BLAKE2B a289df0d54edac838d43db1b37bec8207277c969c663cb958501c7d56b6e4765b1eb1e2d42b76f41c3bf46b9a411ada9cb916e91d9d1c653104f2ced49361aa3 SHA512 a6e11821c8c1f2a8a92f5ec2a9039058421f73610dcbeb64c9d36f9118114610a415da76025f5ae7c0aa46fb81e210ccb51f103ce8858bb189431a44268dc203
MISC metadata.xml 436 BLAKE2B 81bb1424cf305f98c15a96afc454de34c0965277a5829c1c299ee6da4c86882aa1d47d45b71cfd3413b82c68b521a0f2b4bcd37c47988a6c171f55ef97f930ef SHA512 63d65b518096cba951f2bdac8b3ff0a602ac23fee7679ba808f27b01644cc612a7223942ba01f26d4c0931f16ccf9be1832be5da650835c6f43396e2076d1d30
diff --git a/dev-python/furo/furo-2024.8.6.ebuild b/dev-python/furo/furo-2024.8.6.ebuild
new file mode 100644
index 000000000000..9afc06b408f3
--- /dev/null
+++ b/dev-python/furo/furo-2024.8.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# sphinx-theme-builder is completely unusable, as it requires pinning
+# to a very-specific nodejs version number, and ofc loves fetching
+# everything from the Internet
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Clean customisable Sphinx documentation theme"
+HOMEPAGE="
+ https://pypi.org/project/furo/
+ https://github.com/pradyunsg/furo/
+"
+SRC_URI="$(pypi_wheel_url)"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
+"
+
+src_unpack() {
+ if [[ ${PKGBUMPING} == ${PVR} ]]; then
+ unzip "${DISTDIR}/${A}" || die
+ fi
+}
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/${P}-py3-none-any.whl"
+}