summaryrefslogtreecommitdiff
path: root/dev-python/funcy/funcy-1.15.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/funcy/funcy-1.15.ebuild')
-rw-r--r--dev-python/funcy/funcy-1.15.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/funcy/funcy-1.15.ebuild b/dev-python/funcy/funcy-1.15.ebuild
new file mode 100644
index 000000000000..c6242b5bfe8a
--- /dev/null
+++ b/dev-python/funcy/funcy-1.15.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+inherit distutils-r1
+
+DESCRIPTION="A collection of fancy functional tools focused on practicality"
+HOMEPAGE="https://github.com/Suor/funcy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/whatever[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ distutils_install_for_testing --via-root
+ pytest || die "Tests fail with ${EPYTHON}"
+}