summaryrefslogtreecommitdiff
path: root/dev-python/fs/fs-2.4.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fs/fs-2.4.13.ebuild')
-rw-r--r--dev-python/fs/fs-2.4.13.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-python/fs/fs-2.4.13.ebuild b/dev-python/fs/fs-2.4.13.ebuild
index 99833ddeba7d..f3878bd3acdd 100644
--- a/dev-python/fs/fs-2.4.13.ebuild
+++ b/dev-python/fs/fs-2.4.13.ebuild
@@ -3,12 +3,12 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 optfeature
-MY_PN="pyfilesystem2"
+MY_P=pyfilesystem2-${PV}
DESCRIPTION="Filesystem abstraction layer"
HOMEPAGE="
https://pypi.org/project/fs/
@@ -17,8 +17,10 @@ HOMEPAGE="
"
# Tests from the PyPI tarball are broken
# https://github.com/PyFilesystem/pyfilesystem2/issues/364
-SRC_URI="https://github.com/PyFilesystem/pyfilesystem2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
+SRC_URI="
+ https://github.com/PyFilesystem/pyfilesystem2/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
@@ -39,6 +41,11 @@ BDEPEND="
distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
distutils_enable_tests pytest
+python_test() {
+ # pytest-xvfb causes test failures due to a zombie Xvfb process
+ epytest -p no:xvfb
+}
+
pkg_postinst() {
optfeature "S3 support" dev-python/boto
optfeature "SFTP support" dev-python/paramiko