summaryrefslogtreecommitdiff
path: root/dev-python/fonttools
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest2
-rw-r--r--dev-python/fonttools/fonttools-4.37.4.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index bdb0868c00e7..d13ef642fa83 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,7 +1,9 @@
DIST fonttools-4.36.0.gh.tar.gz 3567028 BLAKE2B 45c2481680a314e101ed3a14915585b503a15853937846a5ceadd15e524f053663e0c6876bb105b0f2593ac790029da48cbede8139be98809764e5a6e3e2b11a SHA512 48a07548f72e9818292c1552675fce94b8ecb876172cd7adb429426c1d987f54a6e0482b7847e48c3b9854821567023cce402c613488d9e17277eff8a615d3c2
DIST fonttools-4.37.2.gh.tar.gz 3593663 BLAKE2B d0e6e7beb370a8611f6c92cb3c0d253cda1a946985dee12d1e911a33d45415e15ecdadd2be3eef3d121ffc27a450ed19bcea7c5b19f562af206ea6207b0c7dee SHA512 5850c31f68a6a7e1476644938ccb69d1213eb218a966a67c72f41fbbbc63cf5ed2f9638ce9497fd0702308ebf5637fc471b32a44b2ebcfbb9f4d3c2898dd626b
DIST fonttools-4.37.3.gh.tar.gz 3594598 BLAKE2B bd2c347e1542c2be4136c75804d95ddc1514c4b131f6754467e4229928391f607d206b6edff1fbce62d270801adac3d53fa187a06983dec6d44c699029a8e47e SHA512 7e8f9d68d59e6e842f2cc7acabd4188a1f5b1beb3437148ecb4ced1144eca5ae6af64c501b8ffedb780c72d84c73d7363d7d6ef3b3fc829bad27cba0c15c5ca9
+DIST fonttools-4.37.4.gh.tar.gz 3595501 BLAKE2B 0b3e9e40ca73e1a612d632116c57d1ef9d641a759bdc570c3389ee603b0d8d98974a41fc0339e6dd4ec0cdbfdb9c5905afcf28b33e39eac6c4dcdba6fe64e860 SHA512 9e9c49732ca1e16a8d5b294423939297278d544456b37f5fd3b1f3eece8d9100834f8d7a8dee5908006a27419fbda06180ac588de5046a59fb243d728314939c
EBUILD fonttools-4.36.0.ebuild 1516 BLAKE2B 7b9540de8ab5c231b1cd133b014e9e0d0a265ea2452ffa5326dc84902708319bbbb02a001216cc0c1f8e1d84cfebcdf1d08ee2710741fdc816d3aca033e7ebca SHA512 2d6f905463b5049d4b95fb0e317c263a2dc8b098c432f2169230070a018eeb4bbd2308a99ba5ee4645e67f6b945fd3ee3b95fb1c47e59a001355f48d8996fae0
EBUILD fonttools-4.37.2.ebuild 1524 BLAKE2B 006a2e378c259889001bb01a0ef51350d34fbc3c59d9445d3669317e66916f6d546ca7be3dfffab3b56505bad8bf9a738f6e093829eedbedde2162e5cfda798b SHA512 30d8c62dc7dc26a9218f1cf7e0a4c9553299b4268bdc6a68556d565598ceda574ba194a090390e46a88606ade224c96ba5f49d4143f6ac79074fdfcb1bba97d0
EBUILD fonttools-4.37.3.ebuild 1562 BLAKE2B 2bb7e510ffad7508d3eab0d98b08a740c60c9d981bcd1934d6b4069604628e481c43f39dd1837b39f32637402fb1148b86018afa8983f40a2454be746d8a67d3 SHA512 11833f0747c5676be2823f60cc28dba9f054f37fa1afeba2c958fdcf3a3d7e5644a09be0470bc6ce8c28b28f743f3271f5e24f6592f7f81ff5b037b3112f6e2f
+EBUILD fonttools-4.37.4.ebuild 1562 BLAKE2B 2bb7e510ffad7508d3eab0d98b08a740c60c9d981bcd1934d6b4069604628e481c43f39dd1837b39f32637402fb1148b86018afa8983f40a2454be746d8a67d3 SHA512 11833f0747c5676be2823f60cc28dba9f054f37fa1afeba2c958fdcf3a3d7e5644a09be0470bc6ce8c28b28f743f3271f5e24f6592f7f81ff5b037b3112f6e2f
MISC metadata.xml 372 BLAKE2B 950ec78bf127250847c6513c22a5108b251afdb000d361068edf9d00d64a5baf6925ba4058bb889724febb28d92abc044c29af5936a48d8e8951b12314b64357 SHA512 03e76e28959bab83fe41c3ee4b55692ced9b1360e73e38a6e8f6e5c06fd1185dcbe0214aea2edff18d248abf252c1877d0d2c2b78b8e088e606c09c34e93e7ac
diff --git a/dev-python/fonttools/fonttools-4.37.4.ebuild b/dev-python/fonttools/fonttools-4.37.4.ebuild
new file mode 100644
index 000000000000..75d1f33eb4b3
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.37.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="
+ https://github.com/fonttools/fonttools/
+ https://pypi.org/project/fonttools/
+"
+SRC_URI="
+ https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ export FONTTOOLS_WITH_CYTHON=1
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ epytest Tests fontTools || die "Tests failed with ${EPYTHON}"
+}