summaryrefslogtreecommitdiff
path: root/dev-python/fonttools
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest2
-rw-r--r--dev-python/fonttools/fonttools-4.54.1.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 61576515d757..7223ee2c75af 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,7 +1,9 @@
DIST fonttools-4.53.0.gh.tar.gz 3847778 BLAKE2B 31cf6e495441aeee90f96d6f96b9eedb581f3ee7e5e6f00f7df41547738e7da24d58b4aeac691c44961f842bbf347b32965b052d84ced88c7ade9c0d95c0367a SHA512 f810c428680c4203af3450c4a4b3a1d0f3f5e06ec7d7aac65e1e4aadf5d1e98f9efa5fed75388c8b0a0dcef5094d9b0586c0a71587360bafc91ad683a961698a
DIST fonttools-4.53.1.gh.tar.gz 3850978 BLAKE2B 9c6b5af2cbde939b82043e29ffbbb23434c7b4bb7d7ce68385de701cdf97792bfb58b39acf5e0843493d4b4c3b70f76df6194c9a2ba4f4dfa7ec46155b9f8ce0 SHA512 c51a439c4c760bc929359ff3010612d00280ff1bfa8e6dd5248f181b3244239b82089727b4b6c81594fec57407f4c20f95497e0e26fe0e75fde30f8680022d07
DIST fonttools-4.54.0.gh.tar.gz 3858868 BLAKE2B edd02f52d094223e4217a85cab10c7c384977cf7a57abaab401b73c8a0fc638b4e23fa44f7f3a728824bc67888ebb7136a3bdce08efe99434d0b07347fc188b6 SHA512 0840c8fbcabd5555c2226bb89cba306e5b792c4ed92063f7c32c26616d9e4b061ae782177a1181a9e891a686ca6265796e50ed7c0acf8c82051697a8618f7623
+DIST fonttools-4.54.1.gh.tar.gz 3863311 BLAKE2B 879edb1d5639b2d5a40d10531209504bf30912804a482be16071673727f693042e3158c65b02dc290bfad91767d3f4df10c62539b400f1d48253acf5bf2b86be SHA512 07e5d2401979fa7b1f926a3e3dfb05c2d712e9056e5bd49f879ed818d1f0ec1eb2435b295e30cd95a4e57288e2ce1c113c96a98093b4b57843bb6e3c9d07a7ad
EBUILD fonttools-4.53.0.ebuild 2479 BLAKE2B 9cbce6c2b99c4262ed0d2b1ba4276f5dd8c50dd75488a3bab3c9bd289dd4af9ccd5a74d257087dda0980cce01c16844c7dccf9ddf9845d5ba77417f1a991abc0 SHA512 7f9bd6c171d50b586b40dfc1c78411ebeeeff362cddb2375357ec86d6f2709676a118ca774cd89210067fb5dfe5aab9e14a44415afc4b093b7f68ac7f6d9bce0
EBUILD fonttools-4.53.1.ebuild 2480 BLAKE2B 4b717209b380796d2c21d0bef0f246419bd51565de86cbeef0f78eee1834aff35181e6cf21baee526e3dbee547d2abe5bdd54643cdaa710956ed65ecf699e8b0 SHA512 55ff7f044d322d1ef0ee86725f9f380622a85172d0a666b0ab1568520082089b251ff95e25e7bbdffd7f37e2f5c7c70429e3e515215d697e4c1ba7372f80a164
EBUILD fonttools-4.54.0.ebuild 2487 BLAKE2B 605d0a950444383dcdf3a1e98cc83298780f861f2b86d8547b00584e917f216f8f996d26f1245a5a632df553b41e5e743605ecc3eeb57af0b4560aca90f1f94d SHA512 7850c1e063395fe234a03d714fff1e130b4ba57019d6c04776414e375146768eff3023b870fee7a30f53efb8abe47442cfe5a8b46db4c33e95c4bf19a69e29ed
+EBUILD fonttools-4.54.1.ebuild 2487 BLAKE2B 605d0a950444383dcdf3a1e98cc83298780f861f2b86d8547b00584e917f216f8f996d26f1245a5a632df553b41e5e743605ecc3eeb57af0b4560aca90f1f94d SHA512 7850c1e063395fe234a03d714fff1e130b4ba57019d6c04776414e375146768eff3023b870fee7a30f53efb8abe47442cfe5a8b46db4c33e95c4bf19a69e29ed
MISC metadata.xml 372 BLAKE2B 950ec78bf127250847c6513c22a5108b251afdb000d361068edf9d00d64a5baf6925ba4058bb889724febb28d92abc044c29af5936a48d8e8951b12314b64357 SHA512 03e76e28959bab83fe41c3ee4b55692ced9b1360e73e38a6e8f6e5c06fd1185dcbe0214aea2edff18d248abf252c1877d0d2c2b78b8e088e606c09c34e93e7ac
diff --git a/dev-python/fonttools/fonttools-4.54.1.ebuild b/dev-python/fonttools/fonttools-4.54.1.ebuild
new file mode 100644
index 000000000000..80efba1ec9e3
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.54.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="
+ https://github.com/fonttools/fonttools/
+ https://pypi.org/project/fonttools/
+"
+SRC_URI="
+ https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+RDEPEND="
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+ test? (
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/munkres[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x FONTTOOLS_WITH_CYTHON=$(usex native-extensions)
+ [[ ${EPYTHON} == pypy3 ]] && FONTTOOLS_WITH_CYTHON=0
+ distutils-r1_python_compile
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # flaky test
+ Tests/ttLib/woff2_test.py::WOFF2ReaderTest::test_get_normal_tables
+ )
+
+ if [[ ${EPYTHON} == pypy3 ]] &&
+ has_version "dev-python/pyxattr[${PYTHON_USEDEP}]" &&
+ {
+ has_version "<dev-python/pypy3_10-exe-7.3.13_p2" ||
+ has_version "<dev-python/pypy3_10-exe-bin-7.3.13_p2"
+ }
+ then
+ EPYTEST_DESELECT+=(
+ # affected by a bug in PyPy/pyxattr
+ # https://github.com/iustin/pyxattr/issues/41
+ Tests/t1Lib/t1Lib_test.py::ReadWriteTest::test_read_with_path
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest \
+ -p rerunfailures --reruns=5 \
+ Tests fontTools || die -n "Tests failed with ${EPYTHON}"
+}