summaryrefslogtreecommitdiff
path: root/dev-python/flufl-lock/flufl-lock-8.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flufl-lock/flufl-lock-8.1.0.ebuild')
-rw-r--r--dev-python/flufl-lock/flufl-lock-8.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/flufl-lock/flufl-lock-8.1.0.ebuild b/dev-python/flufl-lock/flufl-lock-8.1.0.ebuild
new file mode 100644
index 000000000000..4cd3b9657779
--- /dev/null
+++ b/dev-python/flufl-lock/flufl-lock-8.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="NFS-safe file locking with timeouts for POSIX systems"
+HOMEPAGE="
+ https://gitlab.com/warsaw/flufl.lock/
+ https://pypi.org/project/flufl.lock/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/sybil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/addopts/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}