summaryrefslogtreecommitdiff
path: root/dev-python/flufl-lock/flufl-lock-7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flufl-lock/flufl-lock-7.1.ebuild')
-rw-r--r--dev-python/flufl-lock/flufl-lock-7.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/flufl-lock/flufl-lock-7.1.ebuild b/dev-python/flufl-lock/flufl-lock-7.1.ebuild
new file mode 100644
index 000000000000..1c3d999df72d
--- /dev/null
+++ b/dev-python/flufl-lock/flufl-lock-7.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="NFS-safe file locking with timeouts for POSIX systems"
+HOMEPAGE="https://gitlab.com/warsaw/flufl.lock"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/sybil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/addopts/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}