summaryrefslogtreecommitdiff
path: root/dev-python/flit_scm/flit_scm-1.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flit_scm/flit_scm-1.7.0.ebuild')
-rw-r--r--dev-python/flit_scm/flit_scm-1.7.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/flit_scm/flit_scm-1.7.0.ebuild b/dev-python/flit_scm/flit_scm-1.7.0.ebuild
new file mode 100644
index 000000000000..e89e6c0577ab
--- /dev/null
+++ b/dev-python/flit_scm/flit_scm-1.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A PEP 518 build backend combining flit with setuptools_scm"
+HOMEPAGE="
+ https://gitlab.com/WillDaSilva/flit_scm/
+ https://pypi.org/project/flit-scm/
+"
+SRC_URI="
+ https://gitlab.com/WillDaSilva/flit_scm/-/archive/${PV}/${P}.tar.bz2
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/flit_core-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-6.4.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ <dev-python/tomli-3[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10 )
+
+"
+
+src_prepare() {
+ # unpin deps
+ sed -i -e 's:~=[0-9.]*::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}