summaryrefslogtreecommitdiff
path: root/dev-python/flexmock/flexmock-0.10.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flexmock/flexmock-0.10.8.ebuild')
-rw-r--r--dev-python/flexmock/flexmock-0.10.8.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/flexmock/flexmock-0.10.8.ebuild b/dev-python/flexmock/flexmock-0.10.8.ebuild
new file mode 100644
index 000000000000..dd44eb32f8f8
--- /dev/null
+++ b/dev-python/flexmock/flexmock-0.10.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing library to create mocks, stubs and fakes"
+HOMEPAGE="https://flexmock.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:flaky
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r docs
+}