summaryrefslogtreecommitdiff
path: root/dev-python/fleep
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fleep')
-rw-r--r--dev-python/fleep/Manifest8
-rw-r--r--dev-python/fleep/fleep-1.0.1-r1.ebuild33
-rw-r--r--dev-python/fleep/fleep-1.0.1.ebuild23
-rw-r--r--dev-python/fleep/fleep-9999.ebuild27
-rw-r--r--dev-python/fleep/metadata.xml2
5 files changed, 57 insertions, 36 deletions
diff --git a/dev-python/fleep/Manifest b/dev-python/fleep/Manifest
index 235b131ab6a7..a898770507fb 100644
--- a/dev-python/fleep/Manifest
+++ b/dev-python/fleep/Manifest
@@ -1,4 +1,4 @@
-DIST fleep-1.0.1.tar.gz 6547 BLAKE2B 75ede77464e32404b3e1229adc9484d1d44b33323ed18f4be5275ffd1c8f63863459f46ff9cbf4f90d0e1387c0e5c967cce13ac8f6ce65710709dd227c04df89 SHA512 ba56f3a6c99f4c793e9f5c4ec04f7a96effabeadd92b18aeb7689a75d8504ccfca086db635d33e358ea9f67887e904c141e259ce2e9b9f3ea77f9e24c1b0eb27
-EBUILD fleep-1.0.1.ebuild 502 BLAKE2B 15f704e4051596dcc441201f887f8365398e8cdd6743f2cedac4e8033b8508ab93cab0b9db3c89f044a581f76bf876ad289fd334c598128c87ef2b6a09ddd12a SHA512 b27cdf484c729e24654e5956f4fd30bbc09a94a28da86988ae1e5f65dac69d85a0d0be46ddec74cea05b9a9d67de79c85e78185d4237a025417e0baa259e39ec
-EBUILD fleep-9999.ebuild 502 BLAKE2B 15f704e4051596dcc441201f887f8365398e8cdd6743f2cedac4e8033b8508ab93cab0b9db3c89f044a581f76bf876ad289fd334c598128c87ef2b6a09ddd12a SHA512 b27cdf484c729e24654e5956f4fd30bbc09a94a28da86988ae1e5f65dac69d85a0d0be46ddec74cea05b9a9d67de79c85e78185d4237a025417e0baa259e39ec
-MISC metadata.xml 394 BLAKE2B b7e3b83459800ddcbd5853411afa08493933b4acf4f9795935fb34e42285d60b75caef1eb6860c15306f9a24421f516da6578518de94d0e4e7c7f3fc0529fc87 SHA512 98e150c1ce256678540131c057c1ce822cbed783a81ac09b7c0230a25f3cb214d2a7f44dd1497d2cef312f000e5114d5171105792807cb789a49d72386c40841
+DIST fleep-1.0.1.gh.tar.gz 197438 BLAKE2B cf099a941d63443a9ee314727966ae95e143acc2f33f7760fe34772d4a2d371af534c029ad207b7727d34e7472c9396b3fc1e9c82066d98ae248dd4f7bd430d7 SHA512 ea287b9cec0f88f378b6c2f248938417e7e51b004a03bb4421611f9cbdae7b97cf1c02b5096c491df934922d906812daadab02d46ae49e64dc2a2a880ab4d87e
+EBUILD fleep-1.0.1-r1.ebuild 863 BLAKE2B 9fe0f5c4a539c0f579d9e4f9bf5b38c449410c22a4c529efc63781463fc3023c31e4e594454fc03de2eba795e23d076c86800fb096a2562e96080b7f24f267cd SHA512 6e0aff23476bfa2fbee81b0c5143d8870fe5aa3cde02139b176caa8a25b88a636924819820d86324145ed2985d021b51b93bdbee3b604cdf0ee0506699c47e57
+EBUILD fleep-9999.ebuild 780 BLAKE2B 43fe8b1004891760053221129190333bdc524c89f21248cbf16b2352103ce82a32bf1d7123fcdfbf0427797ac477944c7fba957771aab151975e7b87ed31e7be SHA512 02e6655ef370e0d76672a46168d34cc04dfd70c7b0dd4743b8009698137bedeb86f0069489590a82bb32d686aca940b7046126592fc3ba1c7fc34416627cf215
+MISC metadata.xml 477 BLAKE2B 04c9a6a91ba95aafd79daeb25d1cf2931576b2cf7a2ead6db1f8607ce54b106cb088f6c2d3974bda6ddc4a3986eb2efb85f90d60c3f32bfa41a1aaed817ecae8 SHA512 72185704ef938ac7d469e8c4766f5b32dd8ecb694601acdd81f853439aee98732f6932359bc1ee69ed4c1cbf16359aa7b7c608309fd2e9685ebddd08bd218e81
diff --git a/dev-python/fleep/fleep-1.0.1-r1.ebuild b/dev-python/fleep/fleep-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..cce82c31af2c
--- /dev/null
+++ b/dev-python/fleep/fleep-1.0.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/floyernick/fleep-py.git"
+ inherit git-r3
+else
+ # upstream aren't tagging the releases, just as commit title
+ COMMIT="994bc2c274482d80ab13d89d8f7343eb316d3e44"
+ # Note: On next bump, remove gh suffix from SRC_URI - was added just for tests
+ SRC_URI="https://github.com/floyernick/fleep-py/archive/${COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/fleep-py-${COMMIT}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="File format determination library for Python"
+HOMEPAGE="https://github.com/floyernick/fleep-py"
+
+LICENSE="MIT"
+SLOT="0"
+
+python_test() {
+ cd tests || die
+ "${EPYTHON}" maintest.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/fleep/fleep-1.0.1.ebuild b/dev-python/fleep/fleep-1.0.1.ebuild
deleted file mode 100644
index 0171f1ef7528..000000000000
--- a/dev-python/fleep/fleep-1.0.1.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="File format determination library for Python"
-HOMEPAGE="https://github.com/floyernick/fleep-py"
-
-if [ "${PV}" = "9999" ]; then
- EGIT_REPO_URI="https://github.com/floyernick/fleep-py.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE=""
diff --git a/dev-python/fleep/fleep-9999.ebuild b/dev-python/fleep/fleep-9999.ebuild
index 0171f1ef7528..68f31790d687 100644
--- a/dev-python/fleep/fleep-9999.ebuild
+++ b/dev-python/fleep/fleep-9999.ebuild
@@ -1,23 +1,32 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
-DESCRIPTION="File format determination library for Python"
-HOMEPAGE="https://github.com/floyernick/fleep-py"
-
-if [ "${PV}" = "9999" ]; then
+if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/floyernick/fleep-py.git"
inherit git-r3
else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ # upstream aren't tagging the releases, just as commit title
+ COMMIT="994bc2c274482d80ab13d89d8f7343eb316d3e44"
+ SRC_URI="https://github.com/floyernick/fleep-py/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/fleep-py-${COMMIT}"
+
KEYWORDS="~amd64 ~x86"
fi
+DESCRIPTION="File format determination library for Python"
+HOMEPAGE="https://github.com/floyernick/fleep-py"
+
LICENSE="MIT"
SLOT="0"
-IUSE=""
+
+python_test() {
+ cd tests || die
+ "${EPYTHON}" maintest.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/fleep/metadata.xml b/dev-python/fleep/metadata.xml
index 9e666fde3716..e0bb47d33be4 100644
--- a/dev-python/fleep/metadata.xml
+++ b/dev-python/fleep/metadata.xml
@@ -8,7 +8,9 @@
<email>zerochaos@gentoo.org</email>
<name>Rick Farina</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">fleep</remote-id>
+ <remote-id type="github">floyernick/fleep-py</remote-id>
</upstream>
</pkgmetadata>