summaryrefslogtreecommitdiff
path: root/dev-python/flask-wtf/flask-wtf-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-wtf/flask-wtf-1.0.0.ebuild')
-rw-r--r--dev-python/flask-wtf/flask-wtf-1.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/flask-wtf/flask-wtf-1.0.0.ebuild b/dev-python/flask-wtf/flask-wtf-1.0.0.ebuild
new file mode 100644
index 000000000000..7052049cc1e8
--- /dev/null
+++ b/dev-python/flask-wtf/flask-wtf-1.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="Flask-WTF"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple integration of Flask and WTForms"
+HOMEPAGE="https://pythonhosted.org/Flask-WTF/ https://pypi.org/project/Flask-WTF/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/Babel-1[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-babel[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tries to access things over the network
+ tests/test_recaptcha.py
+ # unpackaged Flask-Uploads
+ tests/test_file.py
+)