summaryrefslogtreecommitdiff
path: root/dev-python/flask-babel/flask-babel-3.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-babel/flask-babel-3.1.0.ebuild')
-rw-r--r--dev-python/flask-babel/flask-babel-3.1.0.ebuild10
1 files changed, 1 insertions, 9 deletions
diff --git a/dev-python/flask-babel/flask-babel-3.1.0.ebuild b/dev-python/flask-babel/flask-babel-3.1.0.ebuild
index dfa1ff6ea2eb..2254ca7709f4 100644
--- a/dev-python/flask-babel/flask-babel-3.1.0.ebuild
+++ b/dev-python/flask-babel/flask-babel-3.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1
@@ -39,11 +39,3 @@ BDEPEND="
distutils_enable_sphinx docs \
dev-python/pallets-sphinx-themes
distutils_enable_tests pytest
-
-src_prepare() {
- # https://github.com/python-babel/flask-babel/pull/215
- sed -i -e 's:^include:exclude:' pyproject.toml || die
- # https://github.com/python-babel/flask-babel/pull/225
- sed -i -e '/pytz/s:\^:>=:' pyproject.toml || die
- distutils-r1_src_prepare
-}