summaryrefslogtreecommitdiff
path: root/dev-python/fido2/fido2-0.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fido2/fido2-0.3.0.ebuild')
-rw-r--r--dev-python/fido2/fido2-0.3.0.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/fido2/fido2-0.3.0.ebuild b/dev-python/fido2/fido2-0.3.0.ebuild
deleted file mode 100644
index 80c22c109c07..000000000000
--- a/dev-python/fido2/fido2-0.3.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
-inherit distutils-r1
-
-DESCRIPTION="Python based FIDO 2.0 library"
-HOMEPAGE="https://github.com/Yubico/python-fido2"
-SRC_URI="https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD-2 MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pyfakefs[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- touch "${S}"/test/__init__.py || die
- esetup.py test
-}