summaryrefslogtreecommitdiff
path: root/dev-python/fastjsonschema/fastjsonschema-2.19.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fastjsonschema/fastjsonschema-2.19.1.ebuild')
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.19.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.19.1.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.19.1.ebuild
new file mode 100644
index 000000000000..e1529c815ca6
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.19.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="
+ https://github.com/horejsek/python-fastjsonschema/
+ https://pypi.org/project/fastjsonschema/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/benchmarks
+)