summaryrefslogtreecommitdiff
path: root/dev-python/faker
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/faker')
-rw-r--r--dev-python/faker/Manifest4
-rw-r--r--dev-python/faker/faker-33.3.0.ebuild43
-rw-r--r--dev-python/faker/faker-33.3.1.ebuild43
3 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/faker/Manifest b/dev-python/faker/Manifest
index 62bf1662125f..42d3bdbd48a6 100644
--- a/dev-python/faker/Manifest
+++ b/dev-python/faker/Manifest
@@ -1,3 +1,7 @@
DIST faker-33.1.0.tar.gz 1850515 BLAKE2B 71ff6e379f195f220af96562daa1876cd0476f321bb881091929b82ce576b30aa6aa11444411eb5cad30d1922fcfc940012f8b3cd36d074defd3336eac5f8a4a SHA512 0a24af11d64588de2a6c22844efcac11eeacc74faf439e4c0e4bca2cd8d3723177d8fdf5e3b0c6286776e659e38397cea80024ffaaae09c17067ae9b13ea983d
+DIST faker-33.3.0.tar.gz 1854655 BLAKE2B 6a877f7d39b9174285cf406d343a2fbfd204eb0648c9964819c9eb0a4c77b866a846e2c6142221d28ef04097ff9a48971d5ea2ed5f93862a3f4bac77c6345959 SHA512 137082c70e37a863a27f1e0fb5ff807a6b8072fc71c53b1f7ace45f19e98398cfe7a7a419f39bd113755ab50939aa6b5991508015e990f18039d4cd61d397964
+DIST faker-33.3.1.tar.gz 1854895 BLAKE2B 15862330622cd257b0d663a67df4141b3673d077858a655def54152878ba290cb0c3480b0dfb40b2c69ac7481b827ac62827545bddd1edc97a1c5e55af35aad4 SHA512 48e1be12bdbcf12b4da44ede6bb0cd3a8937308f50e4145bbaf1fc80a3fb51dc430e03b5c4bf9a99fce66ea5cac9c5a8e806d036e4052588971ed264c8c472aa
EBUILD faker-33.1.0.ebuild 1008 BLAKE2B da51ee33d20bd3dd0e146139e5fe84bbbd1e9da34fab57638f69651f2cfb65b887b7dc6abbdacce1f12ca2fb10c51b8d6e4a3aa223f699d068023136880faa8e SHA512 d93818fe6bc635465880c85cc659a0295570b04c99909a72fe705ae872d0f9d5c581ce0afd07a89a8c756335cfd7222f8c0d2c9742b3ee2bba1c16ab0bf74b69
+EBUILD faker-33.3.0.ebuild 1015 BLAKE2B 0010aac368c7c89b55a7bc1058e0639596c55be800975a80635cb102c7c8c66e94ae74b2257444985b404fd2e50dc6e3fe31453bc9c5cc47e4d7c1dc2e585d5a SHA512 7924dff75757fac609b9b78689689715585cad26e0fee717aef93251f70281231242f45bac956c368274fc7c93cab70369618b78df200ddb0992bb066f71ee74
+EBUILD faker-33.3.1.ebuild 1015 BLAKE2B 0010aac368c7c89b55a7bc1058e0639596c55be800975a80635cb102c7c8c66e94ae74b2257444985b404fd2e50dc6e3fe31453bc9c5cc47e4d7c1dc2e585d5a SHA512 7924dff75757fac609b9b78689689715585cad26e0fee717aef93251f70281231242f45bac956c368274fc7c93cab70369618b78df200ddb0992bb066f71ee74
MISC metadata.xml 498 BLAKE2B c9b7885dc7d34f2263068624a6b07ac6f1ec8078cc11abb6137612ba57edffefc48dae2708284aa83ecc941ebb2d3b8a87a143648e404a0683e75bb6c078f4e2 SHA512 0b385bbbfbb026803526e43c6c43965ff75f42d3ab133603708b187686aac29de508856e5e8ae7622a66b99032efa97f95c21625e10d074c858d8aff7446a312
diff --git a/dev-python/faker/faker-33.3.0.ebuild b/dev-python/faker/faker-33.3.0.ebuild
new file mode 100644
index 000000000000..b0c932d87fbe
--- /dev/null
+++ b/dev-python/faker/faker-33.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+# note: tests are flaky with xdist
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
+ epytest
+ epytest --exclusive-faker-session tests/pytest/session_overrides
+}
diff --git a/dev-python/faker/faker-33.3.1.ebuild b/dev-python/faker/faker-33.3.1.ebuild
new file mode 100644
index 000000000000..b0c932d87fbe
--- /dev/null
+++ b/dev-python/faker/faker-33.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+# note: tests are flaky with xdist
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
+ epytest
+ epytest --exclusive-faker-session tests/pytest/session_overrides
+}