summaryrefslogtreecommitdiff
path: root/dev-python/execnet/execnet-2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/execnet/execnet-2.0.0.ebuild')
-rw-r--r--dev-python/execnet/execnet-2.0.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/execnet/execnet-2.0.0.ebuild b/dev-python/execnet/execnet-2.0.0.ebuild
deleted file mode 100644
index 707301d05fca..000000000000
--- a/dev-python/execnet/execnet-2.0.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Rapid multi-Python deployment"
-HOMEPAGE="
- https://codespeak.net/execnet/
- https://github.com/pytest-dev/execnet/
- https://pypi.org/project/execnet/
-"
-SRC_URI="
- https://github.com/pytest-dev/execnet/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx doc
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local -x PYTHONDONTWRITEBYTECODE=
- epytest
-}