summaryrefslogtreecommitdiff
path: root/dev-python/envisage
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/envisage')
-rw-r--r--dev-python/envisage/Manifest3
-rw-r--r--dev-python/envisage/envisage-4.4.0.ebuild37
-rw-r--r--dev-python/envisage/metadata.xml18
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/envisage/Manifest b/dev-python/envisage/Manifest
new file mode 100644
index 000000000000..f62d94fe17c2
--- /dev/null
+++ b/dev-python/envisage/Manifest
@@ -0,0 +1,3 @@
+DIST envisage-4.4.0.tar.gz 192529 BLAKE2B 2ce1903d082d5762d5c3d3924c8bfafd4d70d7114461a044bfe55e48bf2ce331119ae649bcbfef143360a67fd54492d7373314681b28de66e47df6d54b888cbe SHA512 7cc8fa82ea9bfd53f1a6cc90551d97972dd4b7abe9476515ea617ab6a32d7f2f65b2815ed934633f96b0f1445b763b9350e5d0e37ed99768c9a2ca32e588f91f
+EBUILD envisage-4.4.0.ebuild 905 BLAKE2B 247628cd3b00449f56e05f2cd4c3ede8261ab5f10665f8266ae36e5b319c32f7a1a36faa07d80a80796462630e5d9f2afb21396be0bb97e9768d9939b3f507b2 SHA512 458c499b539255115085956c1d6fd6f6f457763516eec824c451cb9afa2f49da08354bb52dbe212bf1b861d93a5e0db7a2ff14f04c1326bd960c093544414d75
+MISC metadata.xml 794 BLAKE2B 3a2f5a4b3ea8738e33cdcfcd8488911ffce9c6a9e0717fa131df0cb6866694d69ef8b2918c486a12bb4b486b9a44a90973394515191ed6ea0546d6ef51c568df SHA512 946f23eb719d8ebda446f0fcfc6ceb2a36389824e700a73338c7754f86da15432f045100c53b4fe8dfa294e416b95d7e1430ee3fa945eb86f517075974ad6abe
diff --git a/dev-python/envisage/envisage-4.4.0.ebuild b/dev-python/envisage/envisage-4.4.0.ebuild
new file mode 100644
index 000000000000..4065db128cc1
--- /dev/null
+++ b/dev-python/envisage/envisage-4.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# py2.6 fails testsuite horribly
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Extensible application framework"
+HOMEPAGE="http://docs.enthought.com/envisage/
+ https://github.com/enthought/envisage
+ https://pypi.org/project/envisage/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=">=dev-python/traits-4[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/traits-4[${PYTHON_USEDEP}]
+ dev-python/apptools[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+# tests are buggy version after version
+RESTRICT=test
+
+python_test() {
+ VIRTUALX_COMMAND="nosetests" virtualmake
+}
diff --git a/dev-python/envisage/metadata.xml b/dev-python/envisage/metadata.xml
new file mode 100644
index 000000000000..d2835ba4a5f0
--- /dev/null
+++ b/dev-python/envisage/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+<longdescription lang="en">
+ Envisage is a Python-based framework for building extensible
+ applications, that is, applications whose functionality can be
+ extended by adding "plug-ins". Envisage provides a standard
+ mechanism for features to be added to an application, whether by the
+ original developer or by someone else. In fact, when you build an
+ application using Envisage, the entire application consists
+ primarily of plug-ins. In this respect, it is similar to the Eclipse
+ and Netbeans frameworks for Java applications.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">envisage</remote-id>
+</upstream>
+</pkgmetadata>