summaryrefslogtreecommitdiff
path: root/dev-python/elementpath/elementpath-2.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/elementpath/elementpath-2.1.3.ebuild')
-rw-r--r--dev-python/elementpath/elementpath-2.1.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/elementpath/elementpath-2.1.3.ebuild b/dev-python/elementpath/elementpath-2.1.3.ebuild
new file mode 100644
index 000000000000..73b63d2a6ee3
--- /dev/null
+++ b/dev-python/elementpath/elementpath-2.1.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="https://github.com/sissaschool/elementpath
+ https://pypi.org/project/elementpath/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest