summaryrefslogtreecommitdiff
path: root/dev-python/egg-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/egg-python')
-rw-r--r--dev-python/egg-python/Manifest6
-rw-r--r--dev-python/egg-python/egg-python-2.25.3-r1.ebuild34
-rw-r--r--dev-python/egg-python/files/egg-python-2.25.3-python-libs.patch59
-rw-r--r--dev-python/egg-python/metadata.xml12
4 files changed, 111 insertions, 0 deletions
diff --git a/dev-python/egg-python/Manifest b/dev-python/egg-python/Manifest
new file mode 100644
index 000000000000..36b4b5ba7b23
--- /dev/null
+++ b/dev-python/egg-python/Manifest
@@ -0,0 +1,6 @@
+AUX egg-python-2.25.3-python-libs.patch 2243 SHA256 649b7bdede190923a504b3a598ac9e2003872da8857a152305048a628795c187 SHA512 f9ddacdcffaaf6933e3ab28f843892a4754677a29987d512ebc3810245fb793f8a242b479e47fd63dc7756c817a510e04cda2548aa6bb4d88ce4649c2b1759ed WHIRLPOOL 015c9bb798dadbc0d64143a151bd2a3d1d978a77348e07473f675ccef6b0e5b722eaf81462e48b06c45176d51b698b28834cb2ef4afc9fb2b00e7a8ba5f98b75
+DIST gnome-python-extras-2.25.3.tar.bz2 370489 SHA256 ca346264e00e193f0866cabd8801d3b7ce70dae7b8b296e41e5b3a45c9b0275c SHA512 6994b8b5d6ccc009edc7ddfad373b9164d8162f1007972652f6086dca30cac6941ab68ef467d15c972ab05c4ae0e19ec72edc2643636d22a01a3f5a719251467 WHIRLPOOL b0adfcef8bbb978d063a932393e17de9c8c519194f40085ecd03824ec4fb4421c84e0a4853a5a2d9fc40c94d8c0c261828447ac5fd69cff4ece39c52fc833590
+EBUILD egg-python-2.25.3-r1.ebuild 1024 SHA256 75f2f74865c16a1101009044588b505ec4544961a94a0ae8a14ac43912860cf5 SHA512 a06a9d650726f8786d863f18c0616357179127b8ec47fbf50feac3ce5f313fc12f191b9a8fa4989e0b8185d55129ac5ce81f216c22ad09021d19e0415245cb3f WHIRLPOOL 5ae9358f0b4af837980f30762dee3635637c11eb36206e0b3f512bf96becb5e158b40243d1d2550b40ece51b3e8180f195829162ef62f6c0256021e8decaea2b
+MISC ChangeLog 2492 SHA256 be372d96f00c3ba5162f0ab5d0faaa6c59e30e9bc052f0ad75fbbbffef4f17fd SHA512 879b8ee01420e535212326cf52f71e354f76d3b7517e2dd48462f89e00b40cb5d4c1843af4365e9b328f70935ef34e66ef691475d25fcf21572381bfbba6c293 WHIRLPOOL c9c0a3135f15f82f84e1a8a8bfa5f2ab849ca9df10b4caf42e4a7814adefe87664de80844b322736870d17baf34687eea84ae5d9d6e08c2e9cbdd2cb63fed984
+MISC ChangeLog-2015 4385 SHA256 88ae52e7d3d460ced3132e774085c6ceaf1add38fae5a0c875a974bcfd4127a7 SHA512 b6ced55522becb22fffa8a03216f209fc3d53a66312c1186546d0995f60a592939c6e7311fed8a78509f362003ec62d1fa70df9cb77f29f113626032ccf4c2e3 WHIRLPOOL b2bb51225462eae3a7bec3eaca7a882fee04dab674b2c6dc0eee6b487ad34553d8816ba371b9ff4bff96faa15cfd991126de644b00ae6ff55c0439e5c6f8f284
+MISC metadata.xml 364 SHA256 55f3931f6a7f09c0869b6801233ecaf5fd1c3a4ec5b8bae4efe327dc16afcaee SHA512 6047332255074115daadcfdfe865fc811c09463a5f4e9f85ae36c52f705b413ac51d4281c18d09652115551603f8c5b1e28bb41cb8db3174d6cb4d9a0c368adf WHIRLPOOL ed86b0c0b3edf6acb04ad24c08b95173a6b24a9366259d6d8d15b5fb9dbd916628ffdab0a34a182f47b98fbf1082aeab65971c7628a8420f822dc487bd62179f
diff --git a/dev-python/egg-python/egg-python-2.25.3-r1.ebuild b/dev-python/egg-python/egg-python-2.25.3-r1.ebuild
new file mode 100644
index 000000000000..03a9cdf3f499
--- /dev/null
+++ b/dev-python/egg-python/egg-python-2.25.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+# We don't support the egg.recent bindings that are also provided - they are
+# deprecated, have deps we don't really want and there are no users in-tree.
+GNOME_ORG_MODULE="gnome-python-extras"
+G_PY_BINDINGS="eggtray"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome-python-common-r1
+
+DESCRIPTION="EggTrayIcon bindings for Python"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=dev-python/libbonobo-python-2.22.1[${PYTHON_USEDEP}]
+ >=dev-python/libgnome-python-2.22.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ gnome-base/gnome-common"
+# eautoreconf needs gnome-base/gnome-common
+
+EXAMPLES=( examples/egg/trayicon.py )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python-libs.patch" #344231
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+ eautoreconf
+ gnome-python-common-r1_src_prepare
+}
diff --git a/dev-python/egg-python/files/egg-python-2.25.3-python-libs.patch b/dev-python/egg-python/files/egg-python-2.25.3-python-libs.patch
new file mode 100644
index 000000000000..ab691272cbb6
--- /dev/null
+++ b/dev-python/egg-python/files/egg-python-2.25.3-python-libs.patch
@@ -0,0 +1,59 @@
+From 7824fd5291f570de3c2c64185035d1a6a0a3445a Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 13 Aug 2012 04:42:47 -0400
+Subject: [PATCH] Replace horrible slow python libs search
+
+---
+ acinclude.m4 | 36 ++----------------------------------
+ 1 files changed, 2 insertions(+), 34 deletions(-)
+
+diff --git a/acinclude.m4 b/acinclude.m4
+index 8694a65..f5373eb 100644
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -59,40 +59,8 @@ $1],dnl
+ [AC_MSG_RESULT(not found)
+ $2])
+ CPPFLAGS="$save_CPPFLAGS"
+-
+- # This bit is copied from Planner. murrayc.
+- # Check for Python library path
+- AC_MSG_CHECKING([for Python library path])
+-
+- # Win32 has libpython25.a instead of libpython2.5.a, so we look
+- # for both. TODO: Only look for libpython25.a on Windows, and for
+- # libpython2.5.a on unix.
+- WIN32_PYTHON_VERSION=`echo $PYTHON_VERSION | sed "s,\.,,"`
+-
+- python_path=`dirname $PYTHON | sed "s,/bin.*$,,"`
+- for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/" ; do
+- if test -e "$i"; then
+- python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print | sed "1q"`
+- if test -n "$python_path" ; then
+- python_lib="python$PYTHON_VERSION"
+- break
+- fi
+-
+- # Additionally test WIN32_PYTHON_VERSION
+- python_path=`find $i -type f -name libpython$WIN32_PYTHON_VERSION.* -print | sed "1q"`
+- if test -n "$python_path" ; then
+- python_lib="python$WIN32_PYTHON_VERSION"
+- break
+- fi
+- fi
+- done
+-
+- python_path=`echo $python_path | sed "s,/libpython.*$,,"`
+- AC_MSG_RESULT([$python_path])
+- if test -z "$python_path" ; then
+- AC_MSG_ERROR([cannot find Python library path])
+- fi
+- AC_SUBST([PYTHON_LDFLAGS],["-L$python_path -l$python_lib"])
++PYTHON_LDFLAGS=`$PYTHON -c "import distutils.sysconfig; print('-L%s -lpython${PYTHON_VERSION}' % distutils.sysconfig.get_config_var('LIBDIR'))"`
++AC_SUBST([PYTHON_LDFLAGS],["$PYTHON_LDFLAGS"])
+ ])
+
+ dnl
+--
+1.7.8.6
+
diff --git a/dev-python/egg-python/metadata.xml b/dev-python/egg-python/metadata.xml
new file mode 100644
index 000000000000..431bd550cb73
--- /dev/null
+++ b/dev-python/egg-python/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>