summaryrefslogtreecommitdiff
path: root/dev-python/ed25519ll
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ed25519ll')
-rw-r--r--dev-python/ed25519ll/Manifest4
-rw-r--r--dev-python/ed25519ll/ed25519ll-0.6.ebuild31
-rw-r--r--dev-python/ed25519ll/metadata.xml16
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/ed25519ll/Manifest b/dev-python/ed25519ll/Manifest
new file mode 100644
index 000000000000..1b852ba136a3
--- /dev/null
+++ b/dev-python/ed25519ll/Manifest
@@ -0,0 +1,4 @@
+DIST ed25519ll-0.6.tar.gz 74782 SHA256 7b75b7e6f4c7e7c172229aa78b13436ca9834ef5893598b49c7163d7ba55adf9 SHA512 03d6e1985371698d2fee9627fa24cd724ae2ce8399f55ef9c88df7166ddf88c4b56abbbf7971eb2c8591a6d703b92fcd52f743ecb5752841849eea23eba0978d WHIRLPOOL 71c914795a7b4fbd047471bc1efdafa6a033bc8c7aa3a4f315bdec5772c0a58574b5bfe94082e7f7173ff053f5438f40276358e2644974144266973487252668
+EBUILD ed25519ll-0.6.ebuild 761 SHA256 a81a8f471227db99fbc32f0096178569b1f44bfc07dedd111facc64465389c45 SHA512 74f951119c0a74496d4b05d9c3045db2dac65c4888db72697d2500bfd093e7dc66c20cffbabafeef8b79c835ff325f93e88dd64d5590cd3c28d41eda0eb4190c WHIRLPOOL 3d40d3793e090880e16583ee8cf4453e977a525c16654885d9fda7408cbf0c55dd9a2b71631d9d2b005c505186e98ff49743910a19e766b020579b13424755ae
+MISC ChangeLog 672 SHA256 c5d492fbc9488a437d0d9569166a3d47ba0ccda9a8908ca4d03e5126e3f7abe5 SHA512 688515e09126f0cdc2f90921cf1bd9da653d08ef2f3f08b19986f4304b709cd8287b51dfc726cad1c24ccdf9d86b4809aa33a4bb9c9a9aefa35134a41abb81ad WHIRLPOOL 44464cae93428388ba4fad9fff4e2711c16fc08a15d696d31ed4f1f7a9d631e5ca6660d0dc746baf5c49c17b348c79d785213b18888ec356a676856babac88ec
+MISC metadata.xml 507 SHA256 101de0be247f69cfbf635d0601dd7136e02e35c5a0227fedb5693ac635c1ca9d SHA512 a058610dfb8512ddb145083644fcaa685dc69fd9b1263bebbe8aeea0f7be9a683607cc5fd84a7c730b173989c745af928a13ca0b96913486c1fbc474ba32b37d WHIRLPOOL 88aa506d33993aaf4905495db72b43adfca618cf4b509a334bc6965a623d513609cdc3ffe03f28584cc1bc7cf0f10a2d5d90d2f68de13a6c3547ee5164d3d600
diff --git a/dev-python/ed25519ll/ed25519ll-0.6.ebuild b/dev-python/ed25519ll/ed25519ll-0.6.ebuild
new file mode 100644
index 000000000000..62a6fb63c32a
--- /dev/null
+++ b/dev-python/ed25519ll/ed25519ll-0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A low-level ctypes wrapper for Ed25519 digital signatures."
+HOMEPAGE="http://bitbucket.org/dholth/ed25519ll/ http://pypi.python.org/pypi/ed25519ll"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+# https://bitbucket.org/dholth/ed25519ll/issues/1/testfailures-with-python-3
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/ed25519ll/metadata.xml b/dev-python/ed25519ll/metadata.xml
new file mode 100644
index 000000000000..786080e13beb
--- /dev/null
+++ b/dev-python/ed25519ll/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">ed25519ll</remote-id>
+ <maintainer status="unknown">
+ <email>dholth@fastmail.fm</email>
+ <name>Daniel Holth</name>
+ </maintainer>
+ <remote-id type="bitbucket">dholth/ed25519ll</remote-id>
+ </upstream>
+</pkgmetadata>